M081 crash [@ StyleSetImpl::FindMatchingContext]

VERIFIED DUPLICATE of bug 68208

Status

()

VERIFIED DUPLICATE of bug 68208
18 years ago
18 years ago

People

(Reporter: greer, Assigned: attinasi)

Tracking

({crash, topcrash})

Trunk
mozilla0.9
x86
Linux
crash, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

18 years ago
Topcrash on the Linux M081 build:

Users are crashing when changing fonts:

(28561592) Comments: Changing Font settings in Preferences.
(28538287) Comment:  in prefs dialog
(28346339) Comments: changing font for Traditional Chinese encoding.
(28348910) Comments: I was changing the font size while reading my mail
(via an IMAP4 server)
(28474863) Comment: I was merely changing the default font (serif type) and 
clicked okay
(28510134) Comments: Changed screen resolution to 75dpi and pressed OK.The
Mozilla crashed


Here's a lengthy trace to chew on:

StyleSetImpl::FindMatchingContext()  
         StyleContextImpl::ShareStyleData()  
         StyleContextImpl::RemapStyle()  
         NS_NewStyleContext()  
         StyleSetImpl::GetContext()  
         StyleSetImpl::ResolvePseudoStyleFor()  
         nsPresContext::ResolvePseudoStyleWithComparator()  
         nsPresContext::ResolvePseudoStyleContextFor()  
         nsComboboxControlFrame::CreateFrameFor()  
         nsCSSFrameConstructor::CreateAnonymousFrames()  
         nsCSSFrameConstructor::CreateAnonymousFrames()  
         nsCSSFrameConstructor::ConstructSelectFrame()  
         nsCSSFrameConstructor::ConstructFrameByTag()  
         nsCSSFrameConstructor::ConstructFrameInternal()  
         nsCSSFrameConstructor::ConstructFrame()  
         nsCSSFrameConstructor::ProcessChildren()  
         nsCSSFrameConstructor::ConstructTableCellFrame()  
         nsCSSFrameConstructor::TableProcessChild()  
         nsCSSFrameConstructor::TableProcessChildren()  
         nsCSSFrameConstructor::ConstructTableRowFrame()  
         nsCSSFrameConstructor::TableProcessChild()  
         nsCSSFrameConstructor::TableProcessChildren()  
         nsCSSFrameConstructor::ConstructTableRowGroupFrame()  
         nsCSSFrameConstructor::TableProcessChild()  
         nsCSSFrameConstructor::TableProcessChildren()  
         nsCSSFrameConstructor::ConstructTableFrame()  
         nsCSSFrameConstructor::ConstructFrameByDisplayType()  
         nsCSSFrameConstructor::ConstructFrameInternal()  
         nsCSSFrameConstructor::ConstructFrame()  
         nsCSSFrameConstructor::ProcessChildren()  
         nsCSSFrameConstructor::ConstructTableCellFrame()  
         nsCSSFrameConstructor::TableProcessChild()  
         nsCSSFrameConstructor::TableProcessChildren()  
         nsCSSFrameConstructor::ConstructTableRowFrame()  
         nsCSSFrameConstructor::TableProcessChild()  
         nsCSSFrameConstructor::TableProcessChildren()  
         nsCSSFrameConstructor::ConstructTableRowGroupFrame()  
         nsCSSFrameConstructor::TableProcessChild()  
         nsCSSFrameConstructor::TableProcessChildren()  
         nsCSSFrameConstructor::ConstructTableFrame()  
         nsCSSFrameConstructor::ConstructFrameByDisplayType()  
         nsCSSFrameConstructor::ConstructFrameInternal()  
         nsCSSFrameConstructor::ConstructFrame()  
         nsCSSFrameConstructor::ProcessBlockChildren()  
         nsCSSFrameConstructor::ConstructBlock()  
         nsCSSFrameConstructor::ConstructFrameByDisplayType()  
         nsCSSFrameConstructor::ConstructFrameInternal()  
         nsCSSFrameConstructor::ConstructFrame()  
         nsCSSFrameConstructor::ProcessChildren()  
         nsCSSFrameConstructor::ConstructDocElementFrame()  
         nsCSSFrameConstructor::ReconstructDocElementHierarchy()  
         StyleSetImpl::ReconstructDocElementHierarchy()  
         PresShell::ReconstructFrames()  
         PresShell::SetPreferenceStyleRules()  
         nsPresContext::PreferenceChanged()  
         PrefChangedCallback()  
         pref_DoCallback()  
         pref_HashPref()  
         PREF_SetCharPref()  
         nsPref::SetCharPref()  
         nsPref::SetUnicharPref()  
         XPTC_InvokeByIndex()  
         nsXPCWrappedNativeClass::CallWrappedMethod()  
         WrappedNative_CallMethod()  
         js_Invoke()  
         js_Interpret()  
         js_Invoke()  
         js_InternalInvoke()  
         JS_CallFunctionValue()  
         nsJSContext::CallEventHandler()  
         nsJSEventListener::HandleEvent()  
         nsEventListenerManager::HandleEventSubType()  
         nsEventListenerManager::HandleEvent()  
         nsXULElement::HandleDOMEvent()  
         PresShell::HandleDOMEventWithTarget()  
         nsButtonBoxFrame::MouseClicked()  
         nsButtonBoxFrame::HandleEvent()  
         PresShell::HandleEventInternal()  
         PresShell::HandleEventWithTarget()  
         nsEventStateManager::CheckForAndDispatchClick()  
         nsEventStateManager::PostHandleEvent()  
         PresShell::HandleEventInternal()  
         PresShell::HandleEvent()  
         nsView::HandleEvent()  
         nsViewManager2::DispatchEvent()  
         HandleEvent()  
         nsWidget::DispatchEvent()  
         nsWidget::DispatchWindowEvent()  
         nsWidget::DispatchMouseEvent()  
         nsWidget::OnButtonReleaseSignal()  
         nsWindow::HandleGDKEvent()  
         dispatch_superwin_event()  
         handle_gdk_event()  
         libgdk-1.2.so.0 + 0x17d00 (0x4071ad00)
(Reporter)

Comment 1

18 years ago
Adding crash and topcrash keywords for tracking.
Keywords: crash, topcrash

Comment 2

18 years ago
Confirming bug on Windows ME (2001040304).
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

18 years ago
Adding qawanted keyword to get some help with reproducing this bug.
Keywords: qawanted
Summary: M081 (Linux -top 10) [@ StyleSetImpl::FindMatchingContext] → M081 crash [@ StyleSetImpl::FindMatchingContext]

Comment 4

18 years ago
Reassigning to attinasi. 
Assignee: karnaze → attinasi
Target Milestone: --- → mozilla0.9
(Assignee)

Comment 5

18 years ago
This is a dup of bug 68208 - fortunately, I have a fix for that one.


*** This bug has been marked as a duplicate of 68208 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 6

18 years ago
Verifications.  Tests (if necessary) were done with 2001052504 on Windows 2000.

Please forgive the spam.
Status: RESOLVED → VERIFIED

Updated

18 years ago
Keywords: qawanted
Crash Signature: [@ StyleSetImpl::FindMatchingContext]
You need to log in before you can comment on or make changes to this bug.