Last Comment Bug 747543 - Convert JIT registration API to use JITChunks in place of JITScripts
: Convert JIT registration API to use JITChunks in place of JITScripts
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla15
Assigned To: Steve Fink [:sfink] [:s:]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-20 14:36 PDT by Steve Fink [:sfink] [:s:]
Modified: 2012-04-26 10:43 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Convert JIT registration API to use JITChunks nearly everywhere in place of JITScripts. (8.60 KB, patch)
2012-04-20 14:36 PDT, Steve Fink [:sfink] [:s:]
bhackett1024: review+
Details | Diff | Review

Description Steve Fink [:sfink] [:s:] 2012-04-20 14:36:43 PDT
Something based on this may finally land, since Intel is helping out with vtune integration. The API needs some further changes to handle chunked compilation. (I've been using this patch for several months now with gdb/jit and recently vtune.)
Comment 1 Steve Fink [:sfink] [:s:] 2012-04-20 14:36:52 PDT
Created attachment 617100 [details] [diff] [review]
Convert JIT registration API to use JITChunks nearly everywhere in place of JITScripts.
Comment 2 Matt Brubeck (:mbrubeck) 2012-04-24 21:01:02 PDT
Sorry, I backed out this bug and bug 730208:
https://hg.mozilla.org/integration/mozilla-inbound/rev/cecc9064c6cb

because one of them apparently caused crashes in xpcshell tests on debug builds:
https://tbpl.mozilla.org/php/getParsedLog.php?id=11180559&tree=Mozilla-Inbound
Comment 3 :Ehsan Akhgari (busy, don't ask for review please) 2012-04-25 07:34:09 PDT
https://hg.mozilla.org/mozilla-central/rev/01252613250c
Comment 4 :Ehsan Akhgari (busy, don't ask for review please) 2012-04-25 07:43:09 PDT
Backed out: https://hg.mozilla.org/mozilla-central/rev/cecc9064c6cb
Comment 5 Steve Fink [:sfink] [:s:] 2012-04-25 16:58:55 PDT
Attempt 2:

https://hg.mozilla.org/integration/mozilla-inbound/rev/c9c3950e04dc
Comment 6 Ed Morley [:emorley] 2012-04-26 10:43:44 PDT
https://hg.mozilla.org/mozilla-central/rev/c9c3950e04dc

Note You need to log in before you can comment on or make changes to this bug.