Closed Bug 747620 Opened 8 years ago Closed 7 years ago

Update the blank favicon in the bookmarks bar

Categories

(Firefox :: Bookmarks & History, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 691594

People

(Reporter: ge3k0s, Unassigned)

References

Details

(Whiteboard: [good first bug][mentor=jaws][lang=css])

Since bug 742419 is resolved. The "blank" favicon (in the bookmarks bar) should be updated to become the generic globe.
I think we'll want to make it so we just don't show the favicon in this scenario.
Status: UNCONFIRMED → NEW
Component: Theme → Bookmarks & History
Ever confirmed: true
QA Contact: theme → bookmarks
Summary: Update the blank favicon to the new generic globe → Update the blank favicon in the bookmarks bar
So we want the same as bug 685059 for the bookmarks ?
Version: 14 Branch → Trunk
(In reply to Guillaume C. [:ge3k0s] from comment #2)
> So we want the same as bug 685059 for the bookmarks ?

I think Jared was suggesting that items with no favicon should be rendered in the Bookmark Toolbar with no icon at all, just as they had been until that dashed-line-box was forced on them a year or two ago.  I tend to agree, since horizontal space is precious in that toolbar, and any icon that doesn't identify a particular web site or distinguish its owner from its neighbors is a useless waste of that precious space.

It's worth noting that the Bookmarks Toolbar is also the home of bookmarklets, none of which has its own icon.  Adding an icon next to each one not only wastes space but also gives the impression that it's a web site, which it isn't.  I happen to use that toolbar exclusively for bookmarklets, so for me, the change in behavior was rather frustrating.

Reverting to the the old behavior would be nice.  I think a step up from that might be to have a configurable option:  No icons / Icons only for sites with a favicon / Icons for every item (including a generic one for sites that have none).

+1 for not forcing icons on favicon-less items in the Bookmarks Toolbar.
Here are the cases that we need to handle:

1) Bookmark has icon and label => show icon and label
2) Bookmark has icon, no label => show icon
3) Bookmark has label, no icon => show label
4) Bookmark has no icon or label => show generic icon (dotted line here would be preferred since the globe/Firefox icon is too closely related with privileged pages)

I hope that clears things up :)
It does for me. Thanks, Jared.
Whiteboard: [good first bug][mentor=jaws][lang=css]
Hello,I would like to work on this bug. And isn't this the same as bug 691594?
See Also: → 691594
Yeah, this is the same as that bug. I'll close this one, let's use 691594 since it was filed first.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 691594
You need to log in before you can comment on or make changes to this bug.