Cannot add/remove Print icon in Composer toolbar

RESOLVED FIXED in seamonkey2.11

Status

SeaMonkey
Composer
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Peter Madsen, Assigned: Ian Neal)

Tracking

({regression})

Trunk
seamonkey2.11
regression
Bug Flags:
in-testsuite -

SeaMonkey Tracking Flags

(seamonkey2.8 wontfix, seamonkey2.9 wontfix, seamonkey2.10 fixed, seamonkey2.11 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:11.0) Gecko/20120312 Firefox/11.0 SeaMonkey/2.8
Build ID: 20120312220748

Steps to reproduce:

I disable the Print icon in Edit -> Preferences -> Composer -> Toolbars


Actual results:

I open the Composer - the Print icon is still visible.


Expected results:

The Print icon should not be visible.

Comment 1

5 years ago
Confirming issue on trunk
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120421 Firefox/14.0a1 SeaMonkey/2.11a1
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: x86 → All
Version: SeaMonkey 2.8 Branch → Trunk

Comment 2

5 years ago
IanN, you changed the ID of the print button didn't you?
(Assignee)

Comment 3

5 years ago
Created attachment 617350 [details] [diff] [review]
Sticking plaster fix [Checked in: Comment 8]

This patch:
* Checks for one format of the button id and if it doesn't exist then tries a second form
Assignee: nobody → iann_bugzilla
Status: NEW → ASSIGNED
Attachment #617350 - Flags: review?(neil)
(Assignee)

Updated

5 years ago
status-seamonkey2.10: --- → affected
status-seamonkey2.11: --- → affected
status-seamonkey2.8: --- → wontfix
status-seamonkey2.9: --- → affected

Comment 4

5 years ago
Comment on attachment 617350 [details] [diff] [review]
Sticking plaster fix [Checked in: Comment 8]

I can't wait for customisable toolbars ;-)
Attachment #617350 - Flags: review?(neil) → review+
(Assignee)

Comment 5

5 years ago
Comment on attachment 617350 [details] [diff] [review]
Sticking plaster fix [Checked in: Comment 8]

[Approval Request Comment]
Regression caused by (bug #): 676991
User impact if declined: print button cannot be hidden
Testing completed (on m-c, etc.): Yes
Risk to taking this patch (and alternatives if risky): Very low risk
String changes made by this patch: None
Attachment #617350 - Flags: approval-comm-beta?
Attachment #617350 - Flags: approval-comm-aurora?
(Assignee)

Updated

5 years ago
Depends on: 676991
Keywords: regression

Comment 6

5 years ago
> +    var button = document.getElementById(id + "Button");
> +    if (!button)
> +      button = document.getElementById(id + "-button");
Hmm can't we do it in a more compact way?

var button = document.getElementById(id + "Button") ||
             document.getElementById(id + "-button");
Comment on attachment 617350 [details] [diff] [review]
Sticking plaster fix [Checked in: Comment 8]

Since the button is still *functional* I'm not going to take in 2.9-beta for the mere fact that we cannot hide it.

Beta is already in release repo, and while I could still technically take final build with a beta-approved patch tonight, I'm not taking this.
Attachment #617350 - Flags: approval-comm-beta?
Attachment #617350 - Flags: approval-comm-beta-
Attachment #617350 - Flags: approval-comm-aurora?
Attachment #617350 - Flags: approval-comm-aurora+
(Assignee)

Updated

5 years ago
Summary: Cannot disable Print icon in Composer → Cannot remove Print icon in Composer toolbar
(Assignee)

Updated

5 years ago
Summary: Cannot remove Print icon in Composer toolbar → Cannot add/remove Print icon in Composer toolbar
(Assignee)

Comment 8

5 years ago
Comment on attachment 617350 [details] [diff] [review]
Sticking plaster fix [Checked in: Comment 8]

Using Ratty's suggestion:
http://hg.mozilla.org/comm-central/rev/32d4b5f03e29
http://hg.mozilla.org/releases/comm-aurora/rev/4f865952d02b
Attachment #617350 - Attachment description: Sticking plaster fix → Sticking plaster fix [Checked in: Comment 8]
(Assignee)

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
status-seamonkey2.10: affected → fixed
status-seamonkey2.11: affected → fixed
status-seamonkey2.9: affected → wontfix
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.11
You need to log in before you can comment on or make changes to this bug.