Images don't show up with PDF saved pages on the Samsung Galaxy SII

RESOLVED INVALID

Status

()

Firefox for Android
General
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: Martijn Wargers (zombie), Unassigned)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(blocking-fennec1.0 -)

Details

(Whiteboard: sumo , URL)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 617336 [details]
saved pdf file on the Samsung Galaxy SII

When saving a page with the "Save as PDF" menu option, none of the images on the page show up in the resulting PDF on my Samsung Galaxy SII. This has Android 2.3.3.
Tested with today's Native trunk build.

I also noticed the same issue with a 2011-10-30, which is before the fix from bug 691061 (which would cause images to show up as black in PDF).
When I open the PDF on desktop, I see images. What should be missing? Does the PDF Reader on the SII just not work?
Keywords: regressionwindow-wanted
Confirmed: I can repro on today's respun nightly on my GalaxyS2:

- Saving a .jpeg from the context menu via long-tap displays finr
- Saving a .pdf from the apps 

The default .PDF Reader is Polaris Office on the Galaxy S2 and it does not repro with the adobe reader. I let mluna know this and tagged the whiteboard with sumo. Recommend we do this for bugs we hit but we know aren't the browser.
Whiteboard: sumo
closing as invalid.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Updated

6 years ago
Resolution: FIXED → INVALID

Updated

6 years ago
blocking-fennec1.0: ? → -
I was able to repro what Martijn saw on the LG Revolution, it turns out that Polaris Reader does not show the image correctly.  I installed adobe reader and I see the images just fine.  Not our bug, but Polaris's.
(Reporter)

Comment 5

6 years ago
Oh, doh, didn't realize this could be a bug in Polaris and I didn't bother to view the pdf file on the desktop.
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.