NSS testsuite crash, Linux/ppc64, assertion failed in PKIX_PL_Shutdown

RESOLVED DUPLICATE of bug 489188

Status

RESOLVED DUPLICATE of bug 489188
7 years ago
7 years ago

People

(Reporter: kaie, Unassigned)

Tracking

({crash})

3.13.5
PowerPC
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
strsclnt crash stack:

#0  0x00000080ecf0a58c in .raise () from /lib64/libc.so.6
#1  0x00000080ecf0c28c in .abort () from /lib64/libc.so.6
#2  0x00000fffa9893524 in PR_Assert (s=0xfffa9b941b0 "numLeakedObjects == 0", file=0xfffa9b941c8 "pkix_pl_lifecycle.c", ln=294) at ../../../../pr/src/io/prlog.c:554
#3  0x00000fffa9b411d4 in PKIX_PL_Shutdown (plContext=0x1002707d920) at pkix_pl_lifecycle.c:294
#4  0x00000fffa9ad8370 in PKIX_Shutdown (plContext=0x1002707d920) at pkix_lifecycle.c:231
#5  0x00000fffa99d33ec in nss_Shutdown () at nssinit.c:1104
#6  0x00000fffa99d3664 in NSS_Shutdown () at nssinit.c:1160
#7  0x000000001000a458 in main (argc=18, argv=0xfffd3d92d28) at strsclnt.c:1538

#3  0x00000fffa9b411d4 in PKIX_PL_Shutdown (plContext=0x1002707d920) at pkix_pl_lifecycle.c:294
294                PORT_Assert(numLeakedObjects == 0);
(gdb) print numLeakedObjects
$1 = 1
(Reporter)

Comment 1

7 years ago
If you have questions regarding the stack or state of the process, let me know. I still have the core file.
(Reporter)

Comment 2

7 years ago
I just saw the same crash on my Linux/i686 system, too.

Assertion failure: numLeakedObjects == 0, at pkix_pl_lifecycle.c:294

selfserv: 0 cache hits; 100 cache misses, 0 cache not reusable
          0 stateless resumes, 0 ticket parse failures
./ssl.sh: line 173: 19556 Aborted                 (core dumped) ${PROFTOOL} ${BINDIR}/selfserv -D -p ${PORT} -d ${P_R_SERVERDIR} -n ${HOSTADDR} ${SERVER_OPTIONS} ${ECC_OPTIONS} -w nss ${sparam} -i ${R_SERVERPID} $verbose
selfserv -b -p 8443 2>/dev/null;
selfserv with PID 19556 killed at Wed Apr 25 16:47:58 CEST 2012
ssl.sh: #2884: kill_selfserv core detection step - Core file is detected - FAILED
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 489188
You need to log in before you can comment on or make changes to this bug.