Intermittent 166750-1.html,test_bug240933.html,749816-1.html,763223-1.html,763702.xhtml | assertion count 2 is more than expected 0 assertions from "ASSERTION: This is unsafe! Fix the caller!" in nsEventDispatcher.cpp, line 559

RESOLVED FIXED in Firefox 24

Status

()

defect
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: philor, Assigned: jimm)

Tracking

(Depends on 1 bug, {assertion, intermittent-failure})

13 Branch
mozilla25
x86
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox24 fixed, firefox25 fixed)

Details

https://tbpl.mozilla.org/php/getParsedLog.php?id=11134060&tree=Mozilla-Aurora
Rev3 WINNT 6.1 mozilla-aurora debug test crashtest on 2012-04-23 14:52:40 PDT for push f53d4a882978

REFTEST INFO | Loading a blank page
++DOMWINDOW == 66 (0B5C75E8) [serial = 2169] [outer = 05309D90]
pldhash: for the table at address 08585E98, the given entrySize of 48 probably favors chaining over double hashing.
...
WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80040111: file e:/builds/moz2_slave/m-aurora-w32-dbg/build/content/base/src/nsFrameLoader.cpp, line 422
...
++DOCSHELL 0943ECD0 == 8 [id = 166]
++DOMWINDOW == 67 (0B48B350) [serial = 2170] [outer = 00000000]
...
++DOMWINDOW == 68 (086F71D0) [serial = 2171] [outer = 0B48B300]
###!!! ASSERTION: This is unsafe! Fix the caller!: 'Error', file e:/builds/moz2_slave/m-aurora-w32-dbg/build/content/events/src/nsEventDispatcher.cpp, line 559
xul!mozilla::scache::PathifyURI+0x000000000033CD99
xul!mozilla::scache::PathifyURI+0x0000000000467465
(whole long apparently busted stack)
###!!! ASSERTION: This is unsafe! Fix the caller!: 'Error', file e:/builds/moz2_slave/m-aurora-w32-dbg/build/content/events/src/nsEventDispatcher.cpp, line 559
(again)
WARNING: Subdocument container has no frame: file e:/builds/moz2_slave/m-aurora-w32-dbg/build/layout/base/nsDocumentViewer.cpp, line 2425
++DOMWINDOW == 69 (08AB8868) [serial = 2172] [outer = 08AB9858]
WARNING: Subdocument container has no frame: file e:/builds/moz2_slave/m-aurora-w32-dbg/build/layout/base/nsDocumentViewer.cpp, line 2425
++DOMWINDOW == 70 (08ABA8E8) [serial = 2173] [outer = 08AB7FF8]
++DOMWINDOW == 71 (09133B80) [serial = 2174] [outer = 0B48B300]
REFTEST TEST-START | file:///c:/talos-slave/test/build/reftest/tests/layout/forms/crashtests/166750-1.html | 905 / 2031 (44%)

Which would make the naive observe think that the assertions came from loading about:blank, though that seems like a lot of ++DOMWINDOW for about:blank.
https://tbpl.mozilla.org/php/getParsedLog.php?id=14998687&tree=Firefox
Summary: Intermittent 166750-1.html | assertion count 2 is more than expected 0 assertions from "ASSERTION: This is unsafe! Fix the caller!" in nsEventDispatcher.cpp, line 559 → Intermittent 166750-1.html, 749816-1.html | assertion count 2 is more than expected 0 assertions from "ASSERTION: This is unsafe! Fix the caller!" in nsEventDispatcher.cpp, line 559
https://tbpl.mozilla.org/php/getParsedLog.php?id=15873497&tree=Mozilla-Inbound&full=1
Summary: Intermittent 166750-1.html, 749816-1.html | assertion count 2 is more than expected 0 assertions from "ASSERTION: This is unsafe! Fix the caller!" in nsEventDispatcher.cpp, line 559 → Intermittent 166750-1.html, 749816-1.html, 763223-1.html | assertion count 2 is more than expected 0 assertions from "ASSERTION: This is unsafe! Fix the caller!" in nsEventDispatcher.cpp, line 559,
https://tbpl.mozilla.org/php/getParsedLog.php?id=17022052&tree=Mozilla-Inbound
Depends on: 735966
Summary: Intermittent 166750-1.html, 749816-1.html, 763223-1.html | assertion count 2 is more than expected 0 assertions from "ASSERTION: This is unsafe! Fix the caller!" in nsEventDispatcher.cpp, line 559, → Intermittent 166750-1.html, 749816-1.html, 763223-1.html, 763702.xhtml | assertion count 2 is more than expected 0 assertions from "ASSERTION: This is unsafe! Fix the caller!" in nsEventDispatcher.cpp, line 559
Whiteboard: [orange]
Smaug, I see you added this assert back in the day. Can you please take a look? I can reproduce it pretty reliably by retriggering Win7 debug crashtests.
Flags: needinfo?(bugs)
Uh, that is bad. But I can't reproduce on linux.
Flags: needinfo?(bugs)
I didn't see stack trace in the logs. Would it be possible to get such?
Yes, click the link at the top of the log for the full log.
https://tbpl.mozilla.org/php/getParsedLog.php?id=24910134&tree=Mozilla-Beta
Keywords: assertion
Summary: Intermittent 166750-1.html, 749816-1.html, 763223-1.html, 763702.xhtml | assertion count 2 is more than expected 0 assertions from "ASSERTION: This is unsafe! Fix the caller!" in nsEventDispatcher.cpp, line 559 → Intermittent 166750-1.html,test_bug240933.html,749816-1.html,763223-1.html,763702.xhtml | assertion count 2 is more than expected 0 assertions from "ASSERTION: This is unsafe! Fix the caller!" in nsEventDispatcher.cpp, line 559
Fixed by bug 873073.
Assignee: nobody → jmathies
Status: NEW → RESOLVED
Closed: 6 years ago
Depends on: 873073
Resolution: --- → FIXED
Target Milestone: --- → mozilla25
You need to log in before you can comment on or make changes to this bug.