Last Comment Bug 748158 - Strip trailing slashes from repository urls before passing them to hgtool.py (in client.py)
: Strip trailing slashes from repository urls before passing them to hgtool.py ...
Status: RESOLVED FIXED
:
Product: MailNews Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: All All
: -- normal (vote)
: Thunderbird 14.0
Assigned To: Mark Banner (:standard8)
:
Mentors:
: 760385 (view as bug list)
Depends on:
Blocks: 698843
  Show dependency treegraph
 
Reported: 2012-04-23 16:02 PDT by Mark Banner (:standard8)
Modified: 2012-08-14 01:31 PDT (History)
3 users (show)
standard8: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
fixed
14+
fixed


Attachments
The fix (1.30 KB, patch)
2012-04-23 16:02 PDT, Mark Banner (:standard8)
bugspam.Callek: review+
standard8: approval‑comm‑aurora+
standard8: approval‑comm‑esr10+
Details | Diff | Splinter Review

Description Mark Banner (:standard8) 2012-04-23 16:02:48 PDT
Created attachment 617686 [details] [diff] [review]
The fix

In running the build automation, I've just picked up a minor issue.

Firefox is using http://hg.mozilla.org/mozilla-central, whereas client.py for Thunderbird is coming out with http://hg.mozilla.org/mozilla-central/

hg share detects this and says:

hg path isn't correct (http://hg.mozilla.org/mozilla-central should be http://hg.mozilla.org/mozilla-central/); clobbering

That's not so good as it means whenever a builder swaps between Thunderbird & Firefox it we'll clobber the hg share directory.

The easiest way to fix this seems to be to strip the trailing slash from the url before passing it to hgtool. Hence we'll match the rest of the automation.

I've pushed the attached patch to try server to verify the correct stripping before I push this:

http://hg.mozilla.org/try-comm-central/rev/1539c6c16bb4
Comment 1 Justin Wood (:Callek) (Away until Aug 29) 2012-04-23 20:30:03 PDT
Comment on attachment 617686 [details] [diff] [review]
The fix

># HG changeset patch
># Parent c671975adf5f1d83b0c77cebb5ce42fc44f5ea14
># User Mark Banner <bugzilla@standard8.plus.com>
>diff --git a/client.py b/client.py
>         if repository is not None:
>-            cmd.append(repository)
>+            cmd.append(repo)
>         check_call_noisy(cmd, retryMax=options.retries)

Nit: |if repo is not None:| instead
Comment 2 Mark Banner (:standard8) 2012-04-23 23:56:26 PDT
Somehow the try server push did an empty patch, no idea how that happened. However, I verified locally with a simple python file:

import sys
for arg in sys.args:
  print arg

and passing that as an option to client.py via --hgtool
Comment 3 Mark Banner (:standard8) 2012-04-24 00:02:08 PDT
Comment on attachment 617686 [details] [diff] [review]
The fix

[Triage Comment]
We want this on aurora as well so that it also gets onto beta and avoids taking unnecessary resources swapping between repos.
Comment 5 Mark Banner (:standard8) 2012-04-24 00:42:01 PDT
Unfortunately also needed to land a bustage fix, but this also simplifies the logic:

https://hg.mozilla.org/comm-central/rev/fbc7135f80a7
https://hg.mozilla.org/releases/comm-aurora/rev/8a041705c46a
Comment 6 Mark Banner (:standard8) 2012-06-01 04:09:43 PDT
We also want this on esr for the next release, so that we're not unnecessarily forcing shares to be re-cloned (and hence wasting time during build and also during release cycles).
Comment 7 Nick Thomas [:nthomas] 2012-06-01 04:10:51 PDT
*** Bug 760385 has been marked as a duplicate of this bug. ***
Comment 8 Mark Banner (:standard8) 2012-07-04 23:28:35 PDT
Callek: This landed before the last merge (a few changesets, you can see by following the child), and so the TM of TB 14 was correct.
Comment 9 Mark Banner (:standard8) 2012-07-13 09:12:37 PDT
Comment on attachment 617686 [details] [diff] [review]
The fix

[Triage Comment]
This has been on trunk for a while now and we want it for ESR as well.
Comment 10 Ludovic Hirlimann [:Usul] 2012-08-14 01:00:17 PDT
(In reply to Mark Banner (:standard8) from comment #9)
> Comment on attachment 617686 [details] [diff] [review]
> The fix
> 
> [Triage Comment]
> This has been on trunk for a while now and we want it for ESR as well.

Did it land on ESR ?
Comment 11 Mark Banner (:standard8) 2012-08-14 01:31:09 PDT
Thanks for the reminder, yes it did:

http://hg.mozilla.org/releases/comm-esr10/rev/32f6a0d3bc6c

Note You need to log in before you can comment on or make changes to this bug.