Linux IME(kinput2): wrong highlighted characters and can not be committed.

VERIFIED DUPLICATE of bug 52416

Status

()

Core
Internationalization
VERIFIED DUPLICATE of bug 52416
17 years ago
17 years ago

People

(Reporter: Yuying Long, Assigned: Masaki Katakai)

Tracking

({intl})

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Build: 03-29 or 04-04 Mtrunk

Steps to reproduce:
1. Launch the browser and go to some Japanese page, e.g. 
http://home.netscape.com/ja
2. In the Search field, type some Japanese characters, don't choose the 
first default Japanese character, then hit space, choose one of other choice 
in candidate window.

Note:
If you choose the first default Japanese character by press space key and go 
circle around back to it, you will see the problem too.

Result:
1. After you move the highlight a few times, the characters in browser 
search field won't match it highlighted characters in IME candidate window.
2. Try to convert the character by press enter key, the characters still keep 
highlighted and there is red underline with it.  
3.You press enter again try to convert it, and this time browser start 
processing search.
(Reporter)

Updated

17 years ago
Summary: Linux IME: wrong highlighted characters and can not be committed. → Linux IME(kinput2): wrong highlighted characters and can not be committed.

Comment 1

17 years ago
Reassign to katakai@japan.sun.com, cc to tajima@eng.sun.com.
Assignee: nhotta → katakai
Keywords: intl

Updated

17 years ago
QA Contact: andreasb → ylong
(Assignee)

Comment 2

17 years ago
I understand this problem happens because candidate window
grabs input focus while composing characters (bug 52416).
Please try the workaround in bug 47568 that configuring
window manager not to give input focus to candidate window.


*** This bug has been marked as a duplicate of 52416 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

17 years ago
Mark as dup for now.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.