Last Comment Bug 748243 - Move test_bug514437.html and test_bug588683-*.html to content/html/content/tests/forms/
: Move test_bug514437.html and test_bug588683-*.html to content/html/content/te...
Status: RESOLVED FIXED
[mentor=mounir][good first bug]
:
Product: Core
Classification: Components
Component: DOM: Core & HTML (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla15
Assigned To: Alice Lieutier
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-23 23:00 PDT by Mounir Lamouri (:mounir)
Modified: 2012-04-27 06:54 PDT (History)
2 users (show)
mounir: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch1 (9.57 KB, patch)
2012-04-25 15:41 PDT, Alice Lieutier
mounir: review+
mounir: checkin+
Details | Diff | Splinter Review

Description Mounir Lamouri (:mounir) 2012-04-23 23:00:53 PDT
Tests in content/html/content/tests/forms/ are only about form controls and try to follow some good practices like having a real test name and test large features instead of small bugs.

Some tests in content/html/content/tests/ could be moved in this directory and I found a few of them recently:
content/html/content/test/test_bug514437.html should be moved to content/html/content/test/forms/test_progress_element.html
and:
content/html/content/test/test_bug588683-*.html should be moved to content/html/content/test/forms/test_form_attribute-*.html

In addition of moving the tests, you can change the <title> and change the top comment (like /** Test for Bug XXXXX **/) to be more explicit about what the test is actually doing.

This is a very good first bug because the hard parts are using mercurial and bugzilla.
Comment 1 Mounir Lamouri (:mounir) 2012-04-23 23:06:56 PDT
Some documentation that might help:
https://developer.mozilla.org/en/Introduction

A lot of interesting pages are linked from there.
Comment 2 Mounir Lamouri (:mounir) 2012-04-24 03:54:56 PDT
I forgot to say that Mochitests are listed in Makefile.in (in the same directory). These files will have to be modified.

More information about mochitests:
https://developer.mozilla.org/en/Mochitest
Comment 3 Alice Lieutier 2012-04-25 15:41:39 PDT
Created attachment 618461 [details] [diff] [review]
patch1

I made all the changes asked for.

I had to slightly change test_progress_element.html so it would pass from the new location in test/forms.
Comment 4 Mounir Lamouri (:mounir) 2012-04-25 15:54:16 PDT
Comment on attachment 618461 [details] [diff] [review]
patch1

Review of attachment 618461 [details] [diff] [review]:
-----------------------------------------------------------------

This looks good but the patch doesn't move the test files. How did you generate it?
Comment 5 Mounir Lamouri (:mounir) 2012-04-25 16:09:46 PDT
Comment on attachment 618461 [details] [diff] [review]
patch1

Review of attachment 618461 [details] [diff] [review]:
-----------------------------------------------------------------

My bad, our tool (splinter review) just doesn't show that information. Neither do the diff view nor the "raw" view from the diff page...
Comment 6 Mounir Lamouri (:mounir) 2012-04-26 02:36:24 PDT
Comment on attachment 618461 [details] [diff] [review]
patch1

Patch pushed to mozilla-inbound. Should be merged to mozilla-central soon.

Congrats for your first patch ;)
Comment 7 Ed Morley [:emorley] 2012-04-27 06:54:42 PDT
https://hg.mozilla.org/mozilla-central/rev/f0dc48f621b9

Congrats on your first patch! Come and join us on IRC (https://wiki.mozilla.org/IRC) on #developers and we'll find something else you can work on if you are interested? :-)

Note You need to log in before you can comment on or make changes to this bug.