Closed Bug 748299 Opened 8 years ago Closed 8 years ago

The tab title is not correctly retrieved from chrome://browser/locale/tabbrowser.properties

Categories

(Mozilla Localizations :: ja / Japanese, defect)

defect
Not set

Tracking

(firefox13 affected, firefox14 affected)

RESOLVED FIXED
Tracking Status
firefox13 --- affected
firefox14 --- affected

People

(Reporter: vladmaniac, Assigned: marsf)

References

()

Details

(Whiteboard: [mozmill-test-failure])

Builds: 
Build identifier: Mozilla/5.0 (X11; Linux i686; rv:14.0) Gecko/20120424 Firefox/14.0a1
Also happening on Firefox 13 

http://mozmill-ci.blargon7.com/#/functional/failure?branch=14.0&platform=All&test=%2FtestTabbedBrowsing%2FtestNewTab.js&func=testNewTab.js%3A%3AtestNewTab 

The correct tab title should be from 

tabs.emptyTabTitle		= (無題)

Instead, it is "New Tab" which is En-US
Depends on: 455553
As what Vlad forgot to mention, the English string is visible when you manually open a new tab (at least as he told me on IRC).
Whiteboard: [mozmill-test-failure]
(In reply to Henrik Skupin (:whimboo) from comment #1)
> As what Vlad forgot to mention, the English string is visible when you
> manually open a new tab (at least as he told me on IRC).

Right, thanks Henrik
"(無題)" means "(Untitled)".

Do you mean that we must change the translation to English "New Tab" for the Mozmill test or any other reason?

http://hg.mozilla.org/qa/mozmill-tests/file/0b7b34d752fe/tests/functional/testTabbedBrowsing/testNewTab.js
(In reply to Masahiko Imanaka [:marsf] from comment #3)
> "(無題)" means "(Untitled)".

We do not use 'Untitled' anymore in en-US. With the new tab page it's now called 'New Tab'. So it would have to be translated accordingly.

> Do you mean that we must change the translation to English "New Tab" for the
> Mozmill test or any other reason?

No, it should still be translated correctly. But in the Mozmill test we can not reference each locale, so we only make use of the en-US string in comments. But the test itself gets the label of the tab and compares it with the property value which has been translated.

Tim, do you have an idea what could be wrong here? Why is the tab title 'New Page' when it should be translated? This issue cannot be seen in a de build btw.
I understand the test.
The test compares with the title of about:newtab ("新しいタブ") and manually opend tab ("(無題)"). And they are not equal:
http://hg.mozilla.org/releases/l10n/mozilla-aurora/ja/file/47eeb04b0b3c/browser/chrome/browser/newTab.dtd
http://hg.mozilla.org/releases/l10n/mozilla-aurora/ja/file/47eeb04b0b3c/browser/chrome/browser/tabbrowser.properties#l16

This is our l10n issue.
Interesting, but the test shouldn't say 'New Tab' but should use your localized value. In such a case it would have been easier to identify the problem.

Vlad, would you mind checking if we read the wrong element? Please file a new bug if that's the case.
On Nightly builds the failure message is:
Correct tab title - 'New Tab' should equal '(無題)'

On Aurora builds the failure message is:
Correct tab title - '新しいタブ' should equal '(無題)'
(In reply to Dave Hunt (:davehunt) from comment #7)
> On Nightly builds the failure message is:
> Correct tab title - 'New Tab' should equal '(無題)'

Tim, has something been changed in Firefox 15.0 in the last couple of days? Looks like we have to handle that on it's own bug. Vlad, would you mind checking this?

> On Aurora builds the failure message is:
> Correct tab title - '新しいタブ' should equal '(無題)'

That sounds like this covers this bug correctly.
I'm not sure it's Firefox 15 specifically... when Nightly was 14 the failure message was incorrect, but with Aurora at 14 it seems fine.
Could be a specific setting in Firefox Nightly which hasn't been enabled on Aurora yet. So lets continue on this part in another bug.

Masahiko, would you mind fixing the localization difference for ja?
(In reply to Henrik Skupin (:whimboo) from comment #10)
> Masahiko, would you mind fixing the localization difference for ja?

Sure.
This failure is constantly happening in our Mozmill tests. Masahiko, when do you have time to get it updated? Would be good to see it fixed.
Thanks for those fixes. Just one more question. Would you mind to also update it for mozilla-central in this case? Reason is that we are also getting the problem there and seeing it fixed would be great.
Looks like all has been fixed. Thanks Masahiko. I will file another bug for the remaining 'New Tab' issue which I don't see why it should be related to this bug.
Assignee: nobody → chimantaea_mirabilis
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.