execCommand("insertParagraph") should work the same as hitting Enter

RESOLVED DUPLICATE of bug 748307

Status

()

Core
Editor
--
enhancement
RESOLVED DUPLICATE of bug 748307
6 years ago
6 years ago

People

(Reporter: ayg, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

execCommand("insertParagraph") has three behaviors in browsers.  Gecko behaves the same as execCommand("formatBlock", false, "p"), which is not useful.  IE overwrites the selection with an empty paragraph, which is also not useful.  WebKit and Opera behave the same as though the user hit the Enter key, which is useful, and is what I specced.
I'm fixing this together with bug 748307, since the work is basically the same.
No longer blocks: 685931
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 748307
You need to log in before you can comment on or make changes to this bug.