We are using the system gcc for libffi

RESOLVED DUPLICATE of bug 748138

Status

RESOLVED DUPLICATE of bug 748138
7 years ago
10 months ago

People

(Reporter: espindola, Unassigned)

Tracking

Trunk
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

From a regular try push

https://tbpl.mozilla.org/php/getParsedLog.php?id=11151922&tree=Try&full=1

gcc -DHAVE_CONFIG_H -I. -I/builds/slave/try-lnx64/build/js/src/ctypes/libffi  -I. -I/builds/slave/try-lnx64/build/js/src/ctypes/libffi/include -Iinclude -I/builds/slave/try-lnx64/build/js/src/ctypes/libffi/src  -Wall -g -fexceptions  -O2  -MT src/prep_cif.lo -MD -MP -MF $depbase.Tpo -c -o src/prep_cif.lo /builds/slave/try-lnx64/build/js/src/ctypes/libffi/src/prep_cif.c

We should probably remove the package providing /usr/bin/gcc to make sure problems like this don't show up again.
Isn't this a build system bug or libffi bug, where they're not respecting the CXX and CXXPLUS envvars ?
Component: Release Engineering → Build Config
Product: mozilla.org → Core
QA Contact: release → build-config
Version: other → Trunk
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 748138

Updated

10 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.