The default bug view has changed. See this FAQ.

crash in nsMsgDatabase::MatchDbName

VERIFIED FIXED in Thunderbird 15.0

Status

MailNews Core
Database
--
critical
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: wsmwk, Assigned: Bienvenu)

Tracking

({crash, regression, topcrash})

Thunderbird 15.0
crash, regression, topcrash

Thunderbird Tracking Flags

(thunderbird12 fixed, thunderbird13 fixed, thunderbird14 fixed)

Details

(Whiteboard: [startupcrash][fixed in 12.0.1], crash signature)

Attachments

(1 attachment)

This bug was filed from the Socorro interface and is 
report bp-9a3223f4-2add-400b-af0a-065942120424 .
============================================================= 

starting in version 12. not seen in beta or alpha.
top 5 crash at present.  about half are startup crash

0	xul.dll	nsMsgDatabase::MatchDbName	mailnews/db/msgdb/src/nsMsgDatabase.cpp:968
1	xul.dll	nsMsgDatabase::FindInCache	mailnews/db/msgdb/src/nsMsgDatabase.cpp:936
2	xul.dll	nsMsgDBService::OpenFolderDB	mailnews/db/msgdb/src/nsMsgDatabase.cpp:134
3	xul.dll	nsImapMailFolder::GetDatabase	mailnews/imap/src/nsImapMailFolder.cpp:641
4	xul.dll	nsImapMailFolder::GetDBFolderInfoAndDB	mailnews/imap/src/nsImapMailFolder.cpp:2118
5	xul.dll	nsMsgDBFolder::ReadDBFolderInfo	mailnews/base/util/nsMsgDBFolder.cpp:664
6	xul.dll	nsMsgDBFolder::GetFlags	mailnews/base/util/nsMsgDBFolder.cpp:1268
7	xul.dll	nsImapIncomingServer::GetNewMessagesForNonInboxFolders	mailnews/imap/src/nsImapIncomingServer.cpp:3043
8	xul.dll	nsImapMailFolder::GetNewMessages	mailnews/imap/src/nsImapMailFolder.cpp:2629
9	xul.dll	nsImapIncomingServer::PerformBiff	mailnews/imap/src/nsImapIncomingServer.cpp:1027
10	xul.dll	NS_InvokeByIndex_P	xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp:102
(Assignee)

Comment 1

5 years ago
Created attachment 617952 [details] [diff] [review]
possible fix
Assignee: nobody → dbienvenu
Attachment #617952 - Flags: review?(mbanner)
(Assignee)

Comment 2

5 years ago
I haven't been able to recreate this crash, but I believe this should fix it.

From this stack, it looks like the user has most likely set the hidden pref to check for new messages in all folders, and one or more of the folders is causing us a problem. I can generate a try server build with the fix if you want to contact some of the users having this issue.
(Assignee)

Comment 3

5 years ago
try server builds should appear here - http://ftp.mozilla.org/pub/mozilla.org/thunderbird-test/try-builds/bienvenu@nventure.com-1437e018e2e2
Attachment #617952 - Flags: review?(mbanner) → review+
(Assignee)

Comment 4

5 years ago
fix landed on trunk - http://hg.mozilla.org/comm-central/rev/406d1046698a
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 15.0
(Assignee)

Comment 5

5 years ago
Comment on attachment 617952 [details] [diff] [review]
possible fix

[Approval Request Comment]
bulletproofing fix.
Attachment #617952 - Flags: approval-comm-beta?
Attachment #617952 - Flags: approval-comm-aurora?
do we know the cause of the regression?

fixed https://getsatisfaction.com/mozilla_messaging/topics/v12_crashing_wont_run_revert_to_last_version // bp-922a4c66-9dcb-486c-9663-000ad2120424

and as bienvenu suspected, also reporter of bp-052e8497-7b3b-4c89-8827-b965d2120425 Bug 748770 - startup crash in nsMsgDatabase::OpenInternal
(Assignee)

Comment 7

5 years ago
(In reply to Wayne Mery (:wsmwk) from comment #6)
> do we know the cause of the regression?
presumably, pluggable store work, though I think there has to be something specifically weird about their profiles, since no one saw this in alpha or beta.
Attachment #617952 - Flags: approval-comm-beta?
Attachment #617952 - Flags: approval-comm-beta+
Attachment #617952 - Flags: approval-comm-aurora?
Attachment #617952 - Flags: approval-comm-aurora+
(Reporter)

Updated

5 years ago
Blocks: 402392
70% are startup.
bp-3ce84a7a-4b41-46d5-9006-db85c2120425 (v15) a rare crash of daily
Keywords: topcrash
Whiteboard: [startupcrash]

Updated

5 years ago
OS: Windows NT → All
Hardware: x86 → All

Updated

5 years ago
Crash Signature: [@ nsMsgDatabase::MatchDbName(nsILocalFile*)] → [@ nsMsgDatabase::MatchDbName(nsILocalFile*)] [@ nsMsgDatabase::OpenInternal(nsILocalFile*, bool, bool, bool)]
Comment on attachment 617952 [details] [diff] [review]
possible fix

[Triage Comment]
Attachment #617952 - Flags: approval-comm-release+
Checked in:

https://hg.mozilla.org/releases/comm-aurora/rev/f4b1b15d0d8b
https://hg.mozilla.org/releases/comm-beta/rev/8899da8df322
https://hg.mozilla.org/releases/comm-release/rev/df893565cbac
status-thunderbird12: --- → fixed
status-thunderbird13: --- → fixed
status-thunderbird14: --- → fixed
Whiteboard: [startupcrash] → [startupcrash][fixed in 12.0.1]
v.fixed in 12.0.1 per crash-stats
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.