If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

GNU make 3.77's wildcard is only broken on Solaris 2.6.

VERIFIED WONTFIX

Status

SeaMonkey
Build Config
P3
normal
VERIFIED WONTFIX
19 years ago
13 years ago

People

(Reporter: Wan-Teh Chang, Assigned: Daniel (Leaf) Nunes)

Tracking

Trunk
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
Mozilla Detailed Unix Build Instructions, Section 3
"Requirements" (http://www.mozilla.org/build/unix-details.html#s3)
says that GNU make 3.77 breaks the NSPR build and
tells people to revert to 3.76.1 until this is fixed.
I submitted a bug report to bug-make@gnu.org and
got an authoritative answer from Paul D. Smith
<pausmith@nortelnetworks.com>.

The wildcard function is broken in GNU make 3.77
built on Solaris 2.6 and above due to an inconsistent
attempt to support large files.  This is a known
problem and will be fixed in the next release of
GNU make.  In the meantime, you can do either of
the following:
1) Build GNU make on Solaris 2.5 or 2.5.1.  When
   running on 2.6+, this make executable will work
   fine except that you won't get large file support
   (not a major issue for most people).
2) After building a (broken) make on Solaris 2.6+, do
   the following:

        $ rm -f glob/*.o
        $ make CFLAGS='-g -O2 -D_LARGEFILE_SOURCE
          -D_FILE_OFFSET_BITS=64'

   You can adjust the -g and -O2 options to taste.
   The resulting make executable will work correctly
   on Solaris 2.6+.

Can you update the Unix build instructions with
this information?  The check in the configure
script for GNU make 3.77 probably should also
be updated.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WONTFIX
(Assignee)

Comment 1

19 years ago
Whenever i add this kind of detail to the build page, i get complaints that it's
a useless detail that noone will ever apply. Ramiro reported problems with 3.77
on a non-solaris machine (redhat linux 6.0, i believe), so i'm inclined to
disbelieve the answer from gnu. It's much less complicated to remove and
reinstall make 3.76
(Reporter)

Comment 2

19 years ago
I verified gnu's answer.

The paragraph in the build instructions reads:
    GNU make 3.77 shipped with a that breaks
    the NSPR build. Revert to 3.76.1 until this
    is fixed.

The first sentence needs work.  (What is "that"?)

Any other problems with GNU make 3.77 should be
reported to bug-make@gnu.org.

Comment 3

19 years ago
Created attachment 334 [details]
Adds a ./configure --with-make-prog=/usr/bin/other-make option

Comment 4

19 years ago
Let's say you can't change your make (no root privileges) but do have a make
under another name. My patches allow you to a) tell configure to use your
program and b) have configure remember and use this until you re-run configure.

Comment 5

19 years ago
Marking Verified/Won't Fix.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

18 years ago
*** Bug 21150 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.