Last Comment Bug 748609 - Permaorange on mozilla-beta testAboutPage | page title match - about: page title is correct
: Permaorange on mozilla-beta testAboutPage | page title match - about: page ti...
Status: RESOLVED FIXED
[perma-orange]
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: Trunk
: ARM Android
: -- normal (vote)
: Firefox 16
Assigned To: Matt Brubeck (:mbrubeck)
:
: Sebastian Kaspari (:sebastian)
Mentors:
Depends on:
Blocks: 762632
  Show dependency treegraph
 
Reported: 2012-04-24 17:17 PDT by Phil Ringnalda (:philor)
Modified: 2012-06-08 04:19 PDT (History)
2 users (show)
bugzillamozillaorg_serge_20140323: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
wontfix
fixed
fixed
-


Attachments
patch (1.22 KB, patch)
2012-04-24 17:34 PDT, Matt Brubeck (:mbrubeck)
mark.finkle: review+
mark.finkle: approval‑mozilla‑aurora+
mark.finkle: approval‑mozilla‑beta+
Details | Diff | Splinter Review
patch 2 (1.81 KB, patch)
2012-06-07 12:20 PDT, Matt Brubeck (:mbrubeck)
mark.finkle: review+
mark.finkle: approval‑mozilla‑aurora+
mark.finkle: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Comment 1 Matt Brubeck (:mbrubeck) 2012-04-24 17:34:32 PDT
Created attachment 618110 [details] [diff] [review]
patch

Alternately we could just disable or hide robocop on beta since we are never shipping native Fennec 13 on any channel.
Comment 2 Mark Finkle (:mfinkle) (use needinfo?) 2012-04-24 17:50:25 PDT
Comment on attachment 618110 [details] [diff] [review]
patch

might as well fix it for the next train
Comment 4 Matt Brubeck (:mbrubeck) 2012-04-24 18:05:05 PDT
Comment on attachment 618110 [details] [diff] [review]
patch

[Approval Request Comment]
One-line test-only change to allow this test to pass on beta-branded builds.
Comment 5 Treeherder Robot 2012-04-24 18:06:49 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=11175814&tree=Mozilla-Beta
Android Tegra 250 mozilla-beta opt test robocop on 2012-04-24 16:20:18
slave: tegra-233

3 INFO TEST-UNEXPECTED-FAIL | testAboutPage | page title match - about: page title is correct
buildbot.slave.commands.TimeoutError: command timed out: 2400 seconds without output, killing pid 20199
Comment 6 Mark Finkle (:mfinkle) (use needinfo?) 2012-04-24 18:33:13 PDT
Comment on attachment 618110 [details] [diff] [review]
patch

tests only and limited to android.
Comment 8 Treeherder Robot 2012-04-25 14:46:16 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=11204127&tree=Mozilla-Beta
Android Tegra 250 mozilla-beta opt test robocop on 2012-04-25 13:47:03
slave: tegra-112

3 INFO TEST-UNEXPECTED-FAIL | testAboutPage | page title match - about: page title is correct
164 INFO TEST-UNEXPECTED-FAIL | testAboutPage | page title match - about: page title is correct
Comment 9 Treeherder Robot 2012-04-25 15:32:25 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=11205941&tree=Mozilla-Beta
Android Tegra 250 mozilla-beta opt test robocop on 2012-04-25 14:28:22
slave: tegra-061

3 INFO TEST-UNEXPECTED-FAIL | testAboutPage | page title match - about: page title is correct
164 INFO TEST-UNEXPECTED-FAIL | testAboutPage | page title match - about: page title is correct
Comment 10 Matt Brubeck (:mbrubeck) 2012-04-25 16:10:07 PDT
https://hg.mozilla.org/releases/mozilla-beta/rev/9a8c1d5f3912
Comment 11 Treeherder Robot 2012-04-25 16:44:30 PDT
mbrubeck
https://tbpl.mozilla.org/php/getParsedLog.php?id=11207924&tree=Mozilla-Beta
Android Tegra 250 mozilla-beta opt test robocop on 2012-04-25 15:49:55
slave: tegra-148

5 INFO TEST-UNEXPECTED-FAIL | testAboutPage | page title match - about: page title is correct
164 INFO TEST-UNEXPECTED-FAIL | testAboutPage | page title match - about: page title is correct
Comment 12 Matt Brubeck (:mbrubeck) 2012-04-25 16:54:29 PDT
This did not fix the problem.  Downloading and running the tinderbox build from the beta channel, it looks like there are actually no default bookmarks created in a new profile.

Nominating as a beta blocker, because this breaks the first-run experience in builds on the beta channel.
Comment 13 Matt Brubeck (:mbrubeck) 2012-04-26 09:46:01 PDT
The bookmarks aren't created in beta 13 because bug 728224 never landed on aurora for version 13.  I'm a little curious why this test was green on Aurora but orange after moving to beta, but in any case it doesn't affect our planned release.  I've hidden robocop on beta for now, since we are never shipping native fennec from the 13.0 branch.
Comment 14 Phil Ringnalda (:philor) 2012-06-05 20:35:04 PDT
Alas, once I finally remembered to unhide robocop for 14-on-beta, seems to be more about beta than about 13-on-beta.
Comment 15 Treeherder Robot 2012-06-05 20:35:40 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=12392889&tree=Mozilla-Beta
Android Tegra 250 mozilla-beta opt test robocop on 2012-06-05 13:10:02
slave: tegra-234

3 INFO TEST-UNEXPECTED-FAIL | testAboutPage | page title match - about: page title is correct
Comment 16 Treeherder Robot 2012-06-05 23:54:33 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=12407873&tree=Mozilla-Beta
Android Tegra 250 mozilla-beta opt test robocop on 2012-06-05 23:10:10
slave: tegra-248

3 INFO TEST-UNEXPECTED-FAIL | testAboutPage | page title match - about: page title is correct
TEST-UNEXPECTED-FAIL | Unable to copy profile to device. | Exception caught while running robocop tests.
Comment 17 Treeherder Robot 2012-06-06 01:08:50 PDT
edmorley
https://tbpl.mozilla.org/php/getParsedLog.php?id=12409037&tree=Mozilla-Beta
Android Tegra 250 mozilla-beta opt test robocop on 2012-06-05 23:54:59
slave: tegra-099

3 INFO TEST-UNEXPECTED-FAIL | testAboutPage | page title match - about: page title is correct
Comment 18 Treeherder Robot 2012-06-06 20:56:50 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=12439586&tree=Mozilla-Beta
Android Tegra 250 mozilla-beta opt test robocop on 2012-06-06 18:53:14
slave: tegra-141

3 INFO TEST-UNEXPECTED-FAIL | testBookmark | bookmarks list has 4 children (the default bookmarks) - got 0, expected 4
3 INFO TEST-UNEXPECTED-FAIL | testAboutPage | page title match - about: page title is correct
Comment 19 Treeherder Robot 2012-06-06 22:21:52 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=12442517&tree=Mozilla-Beta
Android Tegra 250 mozilla-beta opt test robocop on 2012-06-06 21:08:24
slave: tegra-174

3 INFO TEST-UNEXPECTED-FAIL | testAboutPage | page title match - about: page title is correct
Comment 20 Treeherder Robot 2012-06-07 03:43:16 PDT
jfkthame
https://tbpl.mozilla.org/php/getParsedLog.php?id=12446935&tree=Mozilla-Beta
Android Tegra 250 mozilla-beta opt test robocop on 2012-06-07 02:24:28
slave: tegra-160

3 INFO TEST-UNEXPECTED-FAIL | testAboutPage | page title match - about: page title is correct
Comment 21 Treeherder Robot 2012-06-07 08:21:28 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=12452652&tree=Mozilla-Beta
Android Tegra 250 mozilla-beta opt test robocop on 2012-06-07 06:39:30
slave: tegra-096

3 INFO TEST-UNEXPECTED-FAIL | testAboutPage | page title match - about: page title is correct
Comment 22 Treeherder Robot 2012-06-07 11:43:23 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=12459549&tree=Mozilla-Beta
Android Tegra 250 mozilla-beta opt test robocop on 2012-06-07 10:44:39
slave: tegra-063

3 INFO TEST-UNEXPECTED-FAIL | testAboutPage | page title match - about: page title is correct
Comment 23 Matt Brubeck (:mbrubeck) 2012-06-07 12:20:13 PDT
Created attachment 631077 [details] [diff] [review]
patch 2

Oops, the original patch here never landed on Aurora for Firefox 14.  Now it needs to land on Beta 14.  In addition, this patch fixes some additional errors that we'll hit on beta after the first patch lands.

[Approval Request Comment]
User impact if declined: Robocop tests are never green on beta.
Risk to taking this patch (and alternatives if risky): Mobile-only test-only fix, to a test that is currently perma-orange.
String or UUID changes made by this patch: None.
Comment 24 Mark Finkle (:mfinkle) (use needinfo?) 2012-06-07 12:32:35 PDT
Comment on attachment 631077 [details] [diff] [review]
patch 2

mobile-only, test-only
Comment 27 Treeherder Robot 2012-06-07 16:34:07 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=12467896&tree=Mozilla-Beta
Android Tegra 250 mozilla-beta opt test robocop on 2012-06-07 16:08:25
slave: tegra-090

3 INFO TEST-UNEXPECTED-FAIL | testAboutPage | page title match - about: page title is correct
TEST-UNEXPECTED-FAIL | Unable to copy profile to device. | Exception caught while running robocop tests.
Comment 28 Graeme McCutcheon [:graememcc] 2012-06-08 04:19:46 PDT
https://hg.mozilla.org/mozilla-central/rev/6fee41489074

(Merged by Ed Morley)

Note You need to log in before you can comment on or make changes to this bug.