Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Upload TiledThebesLayerOGL outside the transaction

RESOLVED FIXED in Firefox 14

Status

()

Core
Graphics
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: BenWa, Assigned: BenWa)

Tracking

unspecified
mozilla15
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(firefox14 fixed, blocking-fennec1.0 beta+)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Created attachment 618150 [details] [diff] [review]
patch

This is causing some regression since we're doing this upload while content is blocked. I wanted to let TiledThebesLayerOGL bake for a day with uploads during the transaction. Note we have another ProcessUploadQueue() in 'TiledThebesLayerOGL::RenderLayer'.
Attachment #618150 - Flags: review?(matt.woodrow)
(Assignee)

Updated

5 years ago
Attachment #618150 - Flags: review?(matt.woodrow) → review?(chrislord.net)

Comment 1

5 years ago
Comment on attachment 618150 [details] [diff] [review]
patch

Review of attachment 618150 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me. Is there a possibility that content could start reusing/destroying tiles before the compositor gets to process them?

::: gfx/layers/opengl/TiledThebesLayerOGL.cpp
@@ +119,5 @@
>  TiledThebesLayerOGL::PaintedTiledLayerBuffer(const BasicTiledLayerBuffer* mTiledBuffer)
>  {
>    mMainMemoryTiledBuffer = *mTiledBuffer;
>    mRegionToUpload.Or(mRegionToUpload, mMainMemoryTiledBuffer.GetLastPaintRegion());
>  

And maybe get rid of this blank line too?
Attachment #618150 - Flags: review?(chrislord.net) → review+
(Assignee)

Comment 2

5 years ago
It is, however the code should copy out the tiles because the compositor will still have a read lock. If that doesn't work then there's a bug with that part of the tiling work and well have to fix it.
(Assignee)

Comment 3

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/d8aa15433e9e
(Assignee)

Comment 4

5 years ago
Comment on attachment 618150 [details] [diff] [review]
patch

[Approval Request Comment]
User impact if declined: Checkerboard reduction
Testing completed (on m-c, etc.): local testing, m-c testing
Risk to taking this patch (and alternatives if risky): Small risk of regressing correctness.
String changes made by this patch: None
Attachment #618150 - Flags: approval-mozilla-aurora?
(Assignee)

Updated

5 years ago
blocking-fennec1.0: --- → ?
blocking-fennec1.0: ? → beta+
Whiteboard: [has reviewed patch]
Comment on attachment 618150 [details] [diff] [review]
patch

[Triage Comment]
Approving, Fennec beta blocker.
Attachment #618150 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/d8aa15433e9e
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla15
Assignee: nobody → bgirard
https://hg.mozilla.org/releases/mozilla-aurora/rev/fa3cd2532fe1
status-firefox14: --- → fixed
(Assignee)

Updated

5 years ago
Whiteboard: [has reviewed patch]
You need to log in before you can comment on or make changes to this bug.