Last Comment Bug 748797 - add a build option that forces MOZ_LINKER_EXTRACT to be enabled
: add a build option that forces MOZ_LINKER_EXTRACT to be enabled
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: ARM Android
: -- normal (vote)
: mozilla15
Assigned To: Ted Mielczarek [:ted.mielczarek]
:
Mentors:
Depends on: 727960
Blocks: 748452
  Show dependency treegraph
 
Reported: 2012-04-25 08:37 PDT by Ted Mielczarek [:ted.mielczarek]
Modified: 2012-05-02 21:34 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
add --enable-android-linker-extract (6.35 KB, patch)
2012-04-27 13:17 PDT, Ted Mielczarek [:ted.mielczarek]
no flags Details | Diff | Splinter Review
support MOZ_LINKER_EXTRACT=1 as a configure option to turn on linker extraction all the time (6.82 KB, patch)
2012-05-01 13:24 PDT, Ted Mielczarek [:ted.mielczarek]
mh+mozilla: review+
blassey.bugs: review+
Details | Diff | Splinter Review

Description Ted Mielczarek [:ted.mielczarek] 2012-04-25 08:37:19 PDT
bug 727960 added/fixed a feature that lets you use MOZ_LINKER_CACHE to specify that the Android linker should load libraries from a specific location on disk. This is handy because you don't have to do the whole package/install dance, you can just push your modified libraries. Benoit noted that it's still a bit of a pain because you have to launch with a very specific commandline, you can't launch from the Android launcher.

We should add a build option to enable this behavior for developer builds, to make launching them easier. Maybe we could even roll in the "load omni.jar from a different location" stuff from bug 745979 while we're at it.
Comment 1 Benoit Girard (:BenWa) 2012-04-25 08:45:15 PDT
That would solve the pain points that have prevented MOZ_LINKER_CACHE from being useful. +1
Comment 2 Ted Mielczarek [:ted.mielczarek] 2012-04-27 13:17:59 PDT
Created attachment 619158 [details] [diff] [review]
add --enable-android-linker-extract
Comment 3 Ted Mielczarek [:ted.mielczarek] 2012-04-27 13:19:44 PDT
This is a WIP patch. It *almost* works, in that all the machinery churns, but /data/local/tmp isn't actually writable by Fennec, so it doesn't do the right thing yet. Need to sort out a sane default there, or just use the default cache location (not sure if adb pushing there works, though, given default android permissions).
Comment 4 Ted Mielczarek [:ted.mielczarek] 2012-05-01 13:24:37 PDT
Created attachment 620048 [details] [diff] [review]
support MOZ_LINKER_EXTRACT=1 as a configure option to turn on linker extraction all the time

This does the trick. Took some fiddling, but works like a charm now.
Comment 5 Mike Hommey [:glandium] 2012-05-01 23:04:02 PDT
Comment on attachment 620048 [details] [diff] [review]
support MOZ_LINKER_EXTRACT=1 as a configure option to turn on linker extraction all the time

Review of attachment 620048 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM, but I'd like a review from one of the mobile peers for the java part.
Comment 6 Ted Mielczarek [:ted.mielczarek] 2012-05-02 07:08:57 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/7e182328da46
Comment 7 :Ehsan Akhgari (away Aug 1-5) 2012-05-02 21:34:19 PDT
https://hg.mozilla.org/mozilla-central/rev/7e182328da46

Note You need to log in before you can comment on or make changes to this bug.