Disable tearing with OpenGL on OS X

RESOLVED FIXED in mozilla15

Status

()

defect
RESOLVED FIXED
7 years ago
4 months ago

People

(Reporter: jrmuizel, Assigned: jrmuizel)

Tracking

(Blocks 1 bug)

unspecified
mozilla15
x86
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: vsync)

Attachments

(1 attachment)

This fixes the problem, I'm not sure if it's the best place to put it.
Whiteboard: [autoland-try]
Whiteboard: [autoland-try] → [autoland-in-queue]
Autoland Patchset:
	Patches: 618315
	Branch: mozilla-central => try
	Destination: http://hg.mozilla.org/try/pushloghtml?changeset=57d8c5757121
Try run started, revision 57d8c5757121. To cancel or monitor the job, see: https://tbpl.mozilla.org/?tree=Try&rev=57d8c5757121
Whiteboard: [autoland-in-queue] → [autoland-try -b do -p all -u all -t all]
removing the tag for autoland, since it's been two weeks - but for next time if you want to use try syntax, you need a : between the [autoland-$branch: try syntax] (i know that's not awesome it's just what we have right now.
Whiteboard: [autoland-try -b do -p all -u all -t all]
Any chance we could find someone to add some UI for this in bugzillaJS or a standalone bugzilla extension?
Attachment #618315 - Flags: review?(bgirard)
Whiteboard: [autoland-try: -b do -p all -u all -t all]
Comment on attachment 618315 [details] [diff] [review]
Set the swap interval to 1

r+ with the assumption this doesn't regress Talos and that we don't spend more time in CGLFlushDrawable blocking the main thread.

http://lists.apple.com/archives/mac-opengl/2009/Aug/msg00022.html
Attachment #618315 - Flags: review?(bgirard) → review+
Would this fix the general tearing that seems to happen when scrolling on OS X 10.6?  (I don't know if we sometimes vs. always use OpenGL.)  If so, that's awesome; I was about to file a bug :)
Do you get any accelerated windows in 'about:support'? Then likely this will.
Yes indeed, so, awesome!  Can't wait for it to land.
Whiteboard: [autoland-try: -b do -p all -u all -t all] → [autoland-try: -b do -p all -u all -t all] vsync
Blocks: 689418
This totally fixes what I was seeing!
Please set the target milestone & assignee when landing on inbound :-)

https://hg.mozilla.org/mozilla-central/rev/4bd5108af8db
Assignee: nobody → jmuizelaar
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla15
Blocks: 759342
Whiteboard: [autoland-try: -b do -p all -u all -t all] vsync → vsync
Blocks: 676248
Blocks: 635566
Duplicate of this bug: 555834
You need to log in before you can comment on or make changes to this bug.