Closed Bug 749106 Opened 8 years ago Closed 8 years ago

Port |Bug 746837 - Fix sessionstore to handle an exception thrown when attempting to focus a window that has been navigated| to SeaMonkey

Categories

(SeaMonkey :: Session Restore, defect, P3)

defect

Tracking

(seamonkey2.11 wontfix)

RESOLVED FIXED
seamonkey2.12
Tracking Status
seamonkey2.11 --- wontfix

People

(Reporter: sgautherie, Assigned: sgautherie)

References

()

Details

Attachments

(1 file, 1 obsolete file)

No description provided.
http://mxr.mozilla.org/comm-central/source/suite/common/src/nsSessionStore.js
1097   undoCloseTab: function sss_undoCloseTab(aWindow, aIndex) {
[...]
Blocks: 749532
(Untested.)
Assignee: nobody → sgautherie.bz
Status: NEW → ASSIGNED
Attachment #621043 - Flags: review?(neil)
Comment on attachment 621043 [details] [diff] [review]
(Av1) Port |Bug 746837 - Fix sessionstore to handle an exception thrown when attempting to focus a window that has been navigated| to SeaMonkey

Please cut out the irrelevant changes.
Attachment #621043 - Flags: review?(neil) → review-
Comment on attachment 621043 [details] [diff] [review]
(Av1) Port |Bug 746837 - Fix sessionstore to handle an exception thrown when attempting to focus a window that has been navigated| to SeaMonkey

(In reply to neil@parkwaycc.co.uk from comment #3)
> Please cut out the irrelevant changes.

Fix:
The main change is the focus call.

Nits:
The other change they did is s/browser/tabbrowser/, which is consistent with the rest of the (SM) file.
The additional change I did is s/var/let/ on the modified lines, to be closer to FF code and as SM file already has a mix of them.

Would you accept them in 2 patches?
Attachment #621043 - Flags: feedback?(neil)
Comment on attachment 621043 [details] [diff] [review]
(Av1) Port |Bug 746837 - Fix sessionstore to handle an exception thrown when attempting to focus a window that has been navigated| to SeaMonkey

OK, fair enough on the browser/tabbrowser changes, but I don't want let.
Attachment #621043 - Flags: feedback?(neil) → feedback+
Attachment #621075 - Flags: review?(neil) → review+
Comment on attachment 621075 [details] [diff] [review]
(Av2) Port |Bug 746837 - Fix sessionstore to handle an exception thrown when attempting to focus a window that has been navigated| to SeaMonkey
[Checked in: Comment 7]

http://hg.mozilla.org/comm-central/rev/dacd84a980a5


[Approval Request Comment]
No risk. Not mandatory, but let's match Firefox.
Attachment #621075 - Attachment description: (Av2) Port |Bug 746837 - Fix sessionstore to handle an exception thrown when attempting to focus a window that has been navigated| to SeaMonkey → (Av2) Port |Bug 746837 - Fix sessionstore to handle an exception thrown when attempting to focus a window that has been navigated| to SeaMonkey [Checked in: Comment 7]
Attachment #621075 - Flags: approval-comm-aurora?
No longer blocks: FF2SM
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Comment on attachment 621075 [details] [diff] [review]
(Av2) Port |Bug 746837 - Fix sessionstore to handle an exception thrown when attempting to focus a window that has been navigated| to SeaMonkey
[Checked in: Comment 7]

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: 
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
String changes made by this patch:
Attachment #621075 - Flags: approval-comm-aurora? → approval-comm-beta?
Comment on attachment 621075 [details] [diff] [review]
(Av2) Port |Bug 746837 - Fix sessionstore to handle an exception thrown when attempting to focus a window that has been navigated| to SeaMonkey
[Checked in: Comment 7]

a- due to "No risk. Not mandatory, but let's match Firefox."
Attachment #621075 - Flags: approval-comm-beta? → approval-comm-beta-
You need to log in before you can comment on or make changes to this bug.