Last Comment Bug 749118 - CSS opacity regression
: CSS opacity regression
Status: RESOLVED FIXED
[qa+]
: regression
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: 10 Branch
: x86_64 All
: -- normal (vote)
: mozilla15
Assigned To: Matt Woodrow (:mattwoodrow)
:
Mentors:
Depends on:
Blocks: 749457 695275
  Show dependency treegraph
 
Reported: 2012-04-26 02:37 PDT by Camaleon
Modified: 2012-06-14 08:28 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
affected
verified
-
verified


Attachments
The animated GIF is rendered as it should (433 bytes, text/html)
2012-04-26 02:37 PDT, Camaleon
no flags Details
The animated GIF losts the second frame (434 bytes, text/html)
2012-04-26 02:38 PDT, Camaleon
no flags Details
A sample background image (123.98 KB, image/jpeg)
2012-04-26 02:39 PDT, Camaleon
no flags Details
A sample GIF animated image (252 bytes, image/gif)
2012-04-26 02:39 PDT, Camaleon
no flags Details
Translate the source correctly (1.24 KB, patch)
2012-04-26 16:49 PDT, Matt Woodrow (:mattwoodrow)
joe: review+
lukasblakk+bugs: approval‑mozilla‑aurora+
lukasblakk+bugs: approval‑mozilla‑beta+
Details | Diff | Review

Description Camaleon 2012-04-26 02:37:49 PDT
Created attachment 618598 [details]
The animated GIF is rendered as it should

There seems to be a regression with CSS opacity in Firefox 12 (or at least it was not present in earlier versions). I am attaching 3 files:

- sample_regression.html (with an opacity level set that exposes the problem)
- sample.html (opacity level set to "1" and working as it should)
- sample.jpg (background image)
- dots.gif (animated gif)

What happens is that when setting the transparency to a layer, the second frame of the animated GIF inside the layer is lost.
Comment 1 Camaleon 2012-04-26 02:38:33 PDT
Created attachment 618599 [details]
The animated GIF losts the second frame
Comment 2 Camaleon 2012-04-26 02:39:04 PDT
Created attachment 618600 [details]
A sample background image
Comment 3 Camaleon 2012-04-26 02:39:38 PDT
Created attachment 618601 [details]
A sample GIF animated image
Comment 4 Alice0775 White 2012-04-26 07:14:40 PDT
Regression window(m-c)
Cannot reproduce:
http://hg.mozilla.org/mozilla-central/rev/e1ae143cc842
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111026 Firefox/10.0a1 ID:20111026120007
Can reproduce:
http://hg.mozilla.org/mozilla-central/rev/16a8d2ab5240
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111026 Firefox/10.0a1 ID:20111026163203
pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e1ae143cc842&tochange=16a8d2ab5240

Regression window(m-i)
Cannot reproduce:
http://hg.mozilla.org/integration/mozilla-inbound/rev/98013fe19dcb
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111025 Firefox/10.0a1 ID:20111025195747
Can reproduce:
http://hg.mozilla.org/integration/mozilla-inbound/rev/d7f3bfc7cd46
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111025 Firefox/10.0a1 ID:20111025203245
pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=98013fe19dcb&tochange=d7f3bfc7cd46

Last good; 68d6ef3d84a3
First bad; 8b89d7037306
Triggered by;
8b89d7037306	Matt Woodrow — Bug 695275 - Fix conversion of ThebesLayers to ImageLayers. r=roc
Comment 5 Matt Woodrow (:mattwoodrow) 2012-04-26 16:49:24 PDT
Created attachment 618856 [details] [diff] [review]
Translate the source correctly
Comment 6 Alex Keybl [:akeybl] 2012-04-30 16:27:30 PDT
This is not a recent regression. Please nominate for Aurora/Beta approval if you'd like to get this in earlier than FF15.
Comment 7 Joe Drew (not getting mail) 2012-05-01 13:51:56 PDT
Comment on attachment 618856 [details] [diff] [review]
Translate the source correctly

Review of attachment 618856 [details] [diff] [review]:
-----------------------------------------------------------------

::: image/src/RasterImage.cpp
@@ +852,5 @@
>                                                               gfxASurface::ImageFormatARGB32);
>    gfxContext ctx(imgsurface);
>    ctx.SetOperator(gfxContext::OPERATOR_SOURCE);
> +  ctx.Rectangle(framerect);
> +  ctx.Translate(framerect.TopLeft());

A better fix to this would be ctx.SetPattern(pattern, framerect.TopLeft());
Comment 8 Matt Woodrow (:mattwoodrow) 2012-05-02 18:45:23 PDT
That API doesn't exist :)

We could adjust the pattern matrix instead? But that doesn't sound easier than my fix, and we'd need to account for a possible existing pattern matrix.
Comment 9 Joe Drew (not getting mail) 2012-05-03 10:52:04 PDT
Comment on attachment 618856 [details] [diff] [review]
Translate the source correctly

Review of attachment 618856 [details] [diff] [review]:
-----------------------------------------------------------------

Oh, I was thinking of SetSource. Sorry!
Comment 10 Matt Woodrow (:mattwoodrow) 2012-05-11 00:51:23 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/15d1960c419e
Comment 11 Matt Brubeck (:mbrubeck) 2012-05-11 11:43:20 PDT
https://hg.mozilla.org/mozilla-central/rev/15d1960c419e
Comment 12 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2012-05-11 15:52:01 PDT
Comment on attachment 618856 [details] [diff] [review]
Translate the source correctly

Review of attachment 618856 [details] [diff] [review]:
-----------------------------------------------------------------

Let's fix this Web-facing regression ASAP
Comment 13 Alex Keybl [:akeybl] 2012-05-11 16:37:38 PDT
(In reply to Robert O'Callahan (:roc) (Mozilla Corporation) from comment #12)
> Let's fix this Web-facing regression ASAP

What's the risk associated with this patch for a FF10 regression?
Comment 14 Matt Woodrow (:mattwoodrow) 2012-05-11 17:13:53 PDT
(In reply to Alex Keybl [:akeybl] from comment #13)
> What's the risk associated with this patch for a FF10 regression?

Should be very low risk, it's just changing the positioning of the image.
Comment 15 Lukas Blakk [:lsblakk] use ?needinfo 2012-05-14 15:25:58 PDT
Comment on attachment 618856 [details] [diff] [review]
Translate the source correctly

sounds low risk enough, approving
Comment 16 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2012-05-14 15:43:54 PDT
I will land this.
Comment 17 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2012-05-14 15:53:08 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/03c10fdb4fd0
https://hg.mozilla.org/releases/mozilla-beta/rev/4ed154f44f8d
Comment 18 Virgil Dicu [:virgil] [QA] 2012-05-30 06:56:18 PDT
Mozilla/5.0 (X11; Linux i686; rv:13.0) Gecko/20100101 Firefox/13.0

Verified in Ubuntu 12.04, Mac OS 10.6 and Windows 7 on Firefox 13 beta 6. Used attachment in comment 0.
Comment 19 Virgil Dicu [:virgil] [QA] 2012-06-14 08:28:18 PDT
Mozilla/5.0 (X11; Linux i686; rv:14.0) Gecko/20100101 Firefox/14.0

Verified in Ubuntu 12.04, Mac OS 10.8 and Windows 7 on Firefox 14 beta 7. Used attachment in comment 0.

Note You need to log in before you can comment on or make changes to this bug.