Last Comment Bug 749139 - MS bitmap fonts are not rendered as expected even if Hardware Acceleration disabled
: MS bitmap fonts are not rendered as expected even if Hardware Acceleration di...
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: x86 Windows 7
: -- normal (vote)
: mozilla15
Assigned To: John Daggett (:jtd)
:
: Milan Sreckovic [:milan]
Mentors:
Depends on:
Blocks: 710727
  Show dependency treegraph
 
Reported: 2012-04-26 04:24 PDT by Alice0775 White
Modified: 2012-04-29 13:52 PDT (History)
5 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch, set the build-on-the-fly flag when font type is non-SFNT (772 bytes, patch)
2012-04-27 00:19 PDT, John Daggett (:jtd)
jfkthame: review+
Details | Diff | Splinter Review

Description Alice0775 White 2012-04-26 04:24:54 PDT
Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/75c7378c87b6
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20120425 Firefox/15.0a1 ID:20120425030647

MS bitmap fonts are not rendered as expected even if Hardware Acceleration disabled.

Reproducible: Always

Steps to Reproduce:
 1. Disable HWA and restart
 2. Open attachment 311969 [details]

Expected results:
  attachment 311971 [details]

Regression window(m-c)
Cannot reproduced:
http://hg.mozilla.org/mozilla-central/rev/a9b543de6b67
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120419 Firefox/14.0a1 ID:20120419015118
Reproduced:
http://hg.mozilla.org/mozilla-central/rev/ee38392142ed
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120419 Firefox/14.0a1 ID:20120419065918
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a9b543de6b67&tochange=ee38392142ed

Regression window(m-i)
Cannot reproduced:
http://hg.mozilla.org/integration/mozilla-inbound/rev/23ad93b7c90a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120418 Firefox/14.0a1 ID:20120418164418
Reproduced:
http://hg.mozilla.org/integration/mozilla-inbound/rev/8094acc0a47e
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120418 Firefox/14.0a1 ID:20120418170418
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=23ad93b7c90a&tochange=8094acc0a47e

Triggered by:
8094acc0a47e	John Daggett — Bug 710727. Share cmaps across all fonts. r=jkew, a=tracking-firefox
Comment 1 John Daggett (:jtd) 2012-04-27 00:19:09 PDT
Created attachment 618945 [details] [diff] [review]
patch, set the build-on-the-fly flag when font type is non-SFNT
Comment 2 John Daggett (:jtd) 2012-04-27 00:19:59 PDT
Making the world safe for crappy fonts, oh joy...
Comment 3 Jonathan Kew (:jfkthame) 2012-04-27 01:20:05 PDT
Comment on attachment 618945 [details] [diff] [review]
patch, set the build-on-the-fly flag when font type is non-SFNT

Review of attachment 618945 [details] [diff] [review]:
-----------------------------------------------------------------

r=me, but please say something like "non-SFNT" rather than "bad" font in the checkin comment.
Comment 4 John Daggett (:jtd) 2012-04-27 01:28:48 PDT
Pushed to inbound
https://hg.mozilla.org/integration/mozilla-inbound/rev/eb4b76b2840f
Comment 5 Ryan VanderMeulen [:RyanVM] 2012-04-29 13:52:52 PDT
http://hg.mozilla.org/mozilla-central/rev/eb4b76b2840f

Note You need to log in before you can comment on or make changes to this bug.