Note: There are a few cases of duplicates in user autocompletion which are being worked on.

TiledThebesLayerOGL can draw un-rendered areas of tiles

RESOLVED FIXED in Firefox 14

Status

()

Core
Graphics: Layers
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: cwiiis, Assigned: BenWa)

Tracking

Trunk
mozilla15
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox12 unaffected, firefox13 unaffected, firefox14 fixed, firefox-esr10 unaffected, blocking-fennec1.0 +)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

5 years ago
When running native android fennec with the patch on bug 607417, and with MOZ_FIXED_POSITION_LAYERS defined, fixed position layers draw areas of the tile that have not been rendered into (and should not be visible).

This can be seen on http://bradfrostweb.com/demo/fixed/index.html

Turning off tiled layer drawing fixes the problem. Turning off retained tiles makes no difference to the behaviour.
(Assignee)

Comment 1

5 years ago
Most likely because we're not respecting the region, should be an easy fix. I'll look at this soon.
blocking-fennec1.0: --- → ?
(Assignee)

Comment 2

5 years ago
Taking the bug. This should be at least a release blocker.
Assignee: nobody → bgirard
blocking-fennec1.0: ? → +
(Assignee)

Comment 3

5 years ago
Created attachment 619153 [details] [diff] [review]
patch
Attachment #619153 - Flags: review?(chrislord.net)
(Assignee)

Comment 4

5 years ago
Created attachment 619162 [details] [diff] [review]
patch
Attachment #619153 - Attachment is obsolete: true
Attachment #619153 - Flags: review?(chrislord.net)
Attachment #619162 - Flags: review?(chrislord.net)
(Assignee)

Updated

5 years ago
Attachment #619162 - Flags: review?(chrislord.net)
(Reporter)

Comment 5

5 years ago
Comment on attachment 619162 [details] [diff] [review]
patch

Review of attachment 619162 [details] [diff] [review]:
-----------------------------------------------------------------

This looks correct to me.
Attachment #619162 - Flags: review?(chrislord.net) → review+
(Reporter)

Comment 6

5 years ago
Created attachment 619196 [details] [diff] [review]
Rebased patch

I r+'d the original patch, but it doesn't apply to current central - here it is, rebased (non-trivial, so this should be reviewed if it's used). Works, but I've only done extremely limited testing.
(Assignee)

Comment 7

5 years ago
Rebase looks good to me. Landing.
(Assignee)

Updated

5 years ago
Attachment #619162 - Attachment is obsolete: true
(Assignee)

Comment 8

5 years ago
Comment on attachment 619196 [details] [diff] [review]
Rebased patch

[Approval Request Comment]
Regression caused by (bug #): Bug 739679 - Add a Shadowable TiledThebesLayer implementation
User impact if declined: Visual glitches for complex layers (non rectangular).
Testing completed (on m-c, etc.): Tested locally to fix a few test cases. I'm looking to allow a few days of bake time on m-c.
Risk to taking this patch (and alternatives if risky): Low, changed the draw region to reflect accurately the input value.
String changes made by this patch: None

Recommending a few days of bake time on m-c to be certain this fixes the problem to make sure we only need to uplift on patch for this problem.
Attachment #619196 - Flags: approval-mozilla-aurora?
(Assignee)

Updated

5 years ago
Duplicate of this bug: 749793

Comment 10

5 years ago
Is there a link to the inbound changeset?
(Assignee)

Comment 11

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/5b46705ba525
Verified fixed on brad's aurora try build.  

http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/blassey@mozilla.com-c3deb5626819
Attachment #619196 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 13

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/72d39007162f
(Assignee)

Updated

5 years ago
status-firefox-esr10: --- → unaffected
status-firefox12: --- → unaffected
status-firefox13: --- → unaffected
status-firefox14: --- → fixed
status-firefox15: --- → affected
https://hg.mozilla.org/mozilla-central/rev/5b46705ba525
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla15

Updated

5 years ago
status-firefox15: affected → ---
You need to log in before you can comment on or make changes to this bug.