Created attachment 618848 [details] [diff] [review] WIP I should probably remove the renaming I did of the appallingly named "foo" local variable.
Created attachment 655379 [details] [diff] [review] part 1: remove the arguments
Comment on attachment 655379 [details] [diff] [review] part 1: remove the arguments Try run looked okay. Kind of a shame we don't have some better way to encapsulate Traverses that want to specify their own name. https://tbpl.mozilla.org/?tree=Try&rev=9dd920702889
Comment on attachment 655380 [details] [diff] [review] part 2: remove the now unused JSContextSize This function was added by Ms2ger to remove jscntxt.h (or whatever) from the exported JS headers, but it isn't needed any more after this patch, so it makes sense to remove it, I think.