Closed Bug 74937 Opened 21 years ago Closed 19 years ago

Confirm move to trash dialog doesn't appear when drag and drop folder to trash.

Categories

(SeaMonkey :: MailNews: Message Display, defect)

defect
Not set
minor

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: wesleyg, Assigned: naving)

References

(Blocks 1 open bug)

Details

(Keywords: qawanted)

Attachments

(1 file)

<summary>
Confirm move to trash dialog doesn't appear when drag and drop folder to trash.

<environment>
build 04-02-04 + Win2000, Mac OS 9.04

<repro steps>
1. open mail
2. go to edit|preferences|mail and newsgroups, check checkbox "confirm when 
moving folders to the trash"
3. create a test folder on a mail server
4. drag and drop that the test folder to the Trash

<Result:>
No confirm dialog appears.

<Expected result:>
Confirm dialog should appear, asking: "Are you sure you want to move the 
selected folder into the Trash?"

Note:
Confirm dialog appears when right clicking on test folder and selecting delete 
folder from the context menu.
QA Contact: esther → sheelar
see bug 62322, bug 24279.

Probably dupe of one of those
Keywords: qawanted
confirming this behavior on both win32 and mac os 9.04/ os x

When you drag and drop a folder no prompt.  This bug is not a duplicate.  We 
should prompt the user when we drag and drop like we do with context menu and 
edit|file menu item.  This behavior is present on the branch builds as well.
Severity: normal → minor
taking
Assignee: sspitzer → naving
>2. go to edit|preferences|mail and newsgroups, check checkbox "confirm when 
>moving folders to the trash"

With this pref checked, user should get the confirmation dialog when dragging 
folders to Trash.
Blocks: 155643
Attached patch proposed fixSplinter Review
The fix is to move the confirm folder deletion logic to copyFolderLocal (where
we actually move the folder).
Cavin, David, Can I get reviews ? thx.
Status: NEW → ASSIGNED
Comment on attachment 91290 [details] [diff] [review]
proposed fix

sr=bienvenu
Attachment #91290 - Flags: superreview+
Comment on attachment 91290 [details] [diff] [review]
proposed fix

r=cavin.
Attachment #91290 - Flags: review+
fixed
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
Drag N drop a local or pop folder to trash now prompts when pref" confirm when 
moving folders to trash is checked.

verified,
2002-09-11-10 -win98
2002-09-11-05 -linux rh 6.2
2002-09-11-03 -mac os x

This does not work for imap folders. No prompt when you DND imap folders to 
trash. Will log a seperate bug for that.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.