Last Comment Bug 749539 - Inline IsContextStable
: Inline IsContextStable
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Canvas: WebGL (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla15
Assigned To: Boris Zbarsky [:bz] (still a bit busy)
:
:
Mentors:
Depends on: 745897
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-27 00:27 PDT by Boris Zbarsky [:bz] (still a bit busy)
Modified: 2012-05-05 20:30 PDT (History)
2 users (show)
bzbarsky: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Make IsContextStable an inline function. (1.67 KB, patch)
2012-04-28 00:58 PDT, Boris Zbarsky [:bz] (still a bit busy)
jacob.benoit.1: review+
Details | Diff | Splinter Review

Description Boris Zbarsky [:bz] (still a bit busy) 2012-04-27 00:27:49 PDT
Maybe PGO does this already, but maybe not.  Depends on whether our training set includes any WebGL.

But I keep seeing this pop up in profiles a bit due to the call overhead.
Comment 1 Ryan VanderMeulen [:RyanVM] 2012-04-27 15:12:56 PDT
No WebGL is included in the PGO suite.
Comment 2 Boris Zbarsky [:bz] (still a bit busy) 2012-04-28 00:58:18 PDT
Created attachment 619259 [details] [diff] [review]
Make IsContextStable an inline function.
Comment 3 Boris Zbarsky [:bz] (still a bit busy) 2012-05-05 06:29:37 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/9a33762c66ef
Comment 4 Ryan VanderMeulen [:RyanVM] 2012-05-05 20:30:10 PDT
https://hg.mozilla.org/mozilla-central/rev/9a33762c66ef

Note You need to log in before you can comment on or make changes to this bug.