Last Comment Bug 749548 - IEProfileMigrator.js and SafariProfileMigrator.js are always in the components manifest
: IEProfileMigrator.js and SafariProfileMigrator.js are always in the component...
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Migration (show other bugs)
: 13 Branch
: All All
: -- normal (vote)
: Firefox 15
Assigned To: Mike Hommey [:glandium]
:
Mentors:
Depends on:
Blocks: 710259 710895
  Show dependency treegraph
 
Reported: 2012-04-27 02:17 PDT by Mike Hommey [:glandium]
Modified: 2012-05-03 09:29 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
unaffected
unaffected
affected


Attachments
Only reference IE and Safari migrators in components manifest when they are installed (2.37 KB, patch)
2012-04-27 02:21 PDT, Mike Hommey [:glandium]
mak77: review+
akeybl: approval‑mozilla‑aurora-
Details | Diff | Splinter Review

Description Mike Hommey [:glandium] 2012-04-27 02:17:31 PDT
On Mac, there is no IEProfileMigrator.js.
On Linux, there is neither.

Yet, in both builds, they both are in the components manifest.
Comment 1 Mike Hommey [:glandium] 2012-04-27 02:21:19 PDT
Created attachment 618955 [details] [diff] [review]
Only reference IE and Safari migrators in components manifest when they are installed
Comment 2 Marco Bonardo [::mak] 2012-04-27 07:07:56 PDT
Comment on attachment 618955 [details] [diff] [review]
Only reference IE and Safari migrators in components manifest when they are installed

Review of attachment 618955 [details] [diff] [review]:
-----------------------------------------------------------------

should be safe to backport to 13 too, so please get approval and do :)
Comment 5 Matthew N. [:MattN] 2012-04-30 12:44:00 PDT
The commit message is misleading because we can't detect "when they are installed" at build time. Something like this would be better:
"Only reference IE and Safari migrators in components manifest on supported operating systems."
Comment 6 Mike Hommey [:glandium] 2012-04-30 12:58:21 PDT
It's "installed" in the "$(NSINSTALL)" sense.
Comment 7 Marco Bonardo [::mak] 2012-05-02 05:21:25 PDT
(In reply to Marco Bonardo [:mak] from comment #2)
> should be safe to backport to 13 too, so please get approval and do :)

I actually meant "backport to 14"... Merge didn't help my numbering.
Comment 8 Mike Hommey [:glandium] 2012-05-02 23:11:55 PDT
Comment on attachment 618955 [details] [diff] [review]
Only reference IE and Safari migrators in components manifest when they are installed

[Approval Request Comment]
Regression caused by: bug 710259 and bug 710895
User impact if declined: No real user impact, but Firefox uselessly tries to registers components that aren't there on Mac and Linux.
Testing completed (on m-c, etc.): Landed on m-c a couple days ago.
Risk to taking this patch (and alternatives if risky): None
String changes made by this patch: None
Comment 9 Alex Keybl [:akeybl] 2012-05-03 09:29:13 PDT
Comment on attachment 618955 [details] [diff] [review]
Only reference IE and Safari migrators in components manifest when they are installed

[Triage Comment]
We don't typically take correctness fixes with no user impact.

Note You need to log in before you can comment on or make changes to this bug.