Fennec doesn't start in landscape mode

VERIFIED FIXED in Firefox 14

Status

()

Firefox for Android
General
VERIFIED FIXED
6 years ago
2 years ago

People

(Reporter: Paul Feher, Assigned: Margaret)

Tracking

Trunk
Firefox 15
ARM
Android
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox14 verified, firefox15 verified, blocking-fennec1.0 +)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 618997 [details]
Log file

Nightly/14.0a1 (2012-04-27)
Device: HTC Desire Z
OS: Android 2.3.3

Steps to reproduce:
Open Fennec app in landscape mode.

Expected result:
Nightly start with about:home page in view.

Actual results:
Nightly doesn't start, only a grey background is displayed.This is happening in 9 out of 10 tries.

NOTE:This issue This is not reproducible on HTC Desire (Android 2.2.2) Samsung Galaxy S2 (Android 2.3.4). Please see the log file attached.
mFormAssistPopup is null?
(Assignee)

Comment 2

6 years ago
I also couldn't reproduce this on a Galaxy Nexus, but it looks like onConfigurationChanged() is getting called before initializing mFormAssistPopup, which means it's getting called before initialize(). I think a null check is the right fix for this problem.

We also call refreshActionBar() in onConfigurationChanged(), which references mBrowserToolbar, but that's initialized in onCreate(), so we shouldn't get a NPE in that case.
Assignee: nobody → margaret.leibovic
(Assignee)

Comment 3

6 years ago
Created attachment 619139 [details] [diff] [review]
patch
Attachment #619139 - Flags: review?(mark.finkle)

Updated

6 years ago
blocking-fennec1.0: --- → ?
Attachment #619139 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 4

6 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/915cb011619f
Target Milestone: --- → Firefox 15
(Assignee)

Comment 5

6 years ago
Comment on attachment 619139 [details] [diff] [review]
patch

[Approval Request Comment]
Regression caused by (bug #): n/a
User impact if declined: startup crash on some devices
Testing completed (on m-c, etc.): just landed on inbound
Risk to taking this patch (and alternatives if risky): low risk (only adds a null check)
String changes made by this patch: n/a
Attachment #619139 - Flags: approval-mozilla-aurora?
http://hg.mozilla.org/mozilla-central/rev/915cb011619f
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Flags: in-testsuite-
Resolution: --- → FIXED

Comment 7

6 years ago
Let's find out if this is blocking fennec 1.0 before approving for Aurora 14.

Comment 8

6 years ago
Comment on attachment 619139 [details] [diff] [review]
patch

[Triage Comment]
Still hasn't gone through blocking triage, but I can't imagine we'd want to leave this very reproducible startup crash unfixed, so I'm just going to approve for Aurora 14.
Attachment #619139 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 9

6 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/6135b86479ac
status-firefox14: --- → fixed
status-firefox15: --- → fixed
(Reporter)

Comment 10

6 years ago
Verified fixed on:
Nightly Fennec 15.0a1 (2012-05-07)
Aurora Fennec 14.0a2 (2012-05-07)
Device: HTC Desire Z
OS: Android 2.3.3

Using the initial STR.
Status: RESOLVED → VERIFIED
status-firefox14: fixed → verified
status-firefox15: fixed → verified
blocking-fennec1.0: ? → +
You need to log in before you can comment on or make changes to this bug.