Last Comment Bug 749589 - Less-leaky classinfo for XTF
: Less-leaky classinfo for XTF
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: 12 Branch
: x86_64 Linux
: -- normal (vote)
: ---
Assigned To: Olli Pettay [:smaug] (high review load, please consider other reviewers)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-27 05:54 PDT by Olli Pettay [:smaug] (high review load, please consider other reviewers)
Modified: 2012-05-11 15:12 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
WIP (5.47 KB, patch)
2012-04-27 06:59 PDT, Olli Pettay [:smaug] (high review load, please consider other reviewers)
jst: review+
Details | Diff | Review

Description Olli Pettay [:smaug] (high review load, please consider other reviewers) 2012-04-27 05:54:19 PDT

    
Comment 1 Olli Pettay [:smaug] (high review load, please consider other reviewers) 2012-04-27 06:59:58 PDT
Created attachment 619016 [details] [diff] [review]
WIP

Classinfo shouldn't keep the object alive.
Comment 2 Olli Pettay [:smaug] (high review load, please consider other reviewers) 2012-04-27 07:02:05 PDT
https://tbpl.mozilla.org/?tree=Try
Comment 3 Olli Pettay [:smaug] (high review load, please consider other reviewers) 2012-04-27 08:48:42 PDT
Comment on attachment 619016 [details] [diff] [review]
WIP

Bill, could you test this?
It should fix the leak you saw where keeping classinfo alive ends up
keeping element alive.
Comment 4 Olli Pettay [:smaug] (high review load, please consider other reviewers) 2012-04-27 13:50:20 PDT
https://tbpl.mozilla.org/?tree=Try&rev=1e3e3ac9452f
Comment 5 Olli Pettay [:smaug] (high review load, please consider other reviewers) 2012-05-02 05:12:14 PDT
Jst, review ping. I believe this block iGC.
Comment 6 Andrew McCreight (PTO-ish through 6-29) [:mccr8] 2012-05-02 07:57:07 PDT
(In reply to Olli Pettay [:smaug] from comment #5)
> Jst, review ping. I believe this block iGC.

No, it doesn't.  This is just an existing leak that we've ignored for years that Bill happened to notice while investigating IGC leaks, if I understand correctly.
Comment 7 Olli Pettay [:smaug] (high review load, please consider other reviewers) 2012-05-02 09:37:32 PDT
Oh, I thought iGC+xpcshell tests were leaking because of this.

But anyhow, Bill, you could test this.
Comment 8 Olli Pettay [:smaug] (high review load, please consider other reviewers) 2012-05-02 09:37:42 PDT
er, could you...
Comment 9 Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-05-02 10:05:52 PDT
(In reply to Olli Pettay [:smaug] from comment #7)
> Oh, I thought iGC+xpcshell tests were leaking because of this.

They are, but non-iGC+xpcshell are too :-)
Comment 10 Bill McCloskey (:billm) 2012-05-02 12:39:50 PDT
Yeah, this fixes the leak. Thanks.

This doesn't block IGC. It's a leak we found while trying to debug the IGC leak. As Rafael said, it leaks on trunk right now.
Comment 11 Olli Pettay [:smaug] (high review load, please consider other reviewers) 2012-05-11 15:12:53 PDT
https://hg.mozilla.org/mozilla-central/rev/22a58090fa70

Note You need to log in before you can comment on or make changes to this bug.