No error dialog if something fails during uncompressing gzip

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
18 years ago
3 years ago

People

(Reporter: matthew2k, Unassigned)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.3-ac2 i686; en-US; 0.8.1)
BuildID:    2001040409

From time to time Mozilla doesn't display/load a page until the reload button is
being pushed. Once this bug has occured it happens quite often until Mozilla is
being restarted. I'm running the wwwoffle proxy along with the webwasher ad
buster. Both support HTTP 1.1 so that shouldn't be a problem. I've been
expierencing this bug for one or two weeks now (+/-) so it's rather new.

Reproducible: Sometimes
Steps to Reproduce:
1.Surf around
2.Suddenly page doesn't load/display. Only blank page is shown.
3.Hit reload


Actual Results:  Page is shown after reload is being hit - otherwise just a
blank page appears.

Expected Results:  Mozilla should always display/load pages.
(Reporter)

Updated

18 years ago
Target Milestone: --- → mozilla0.9
(Reporter)

Comment 1

18 years ago
Maybe this is of help. Since this bug was introduced into Mozilla, loading of
pages while offline (through the WWWOffle proxy) doesn't work anymore. Mozilla
just shows a blank page without any notice what error occured. Nevertheless,
loading the general WWWOffle page (http://localhost:8080) works fine though. I
also checked if this problem could be related to WWWOffle itself by trying Opera
and Netscape 4.7x - both worked fine without any problems. Furthermore pages
with frames are diffcult to load also. Just hitting the reload button doesn't
work. Usually you have to reload each frame when this bug occurs...

Comment 2

18 years ago
Milestone is for the assignee.  Confirming so that someone will look at this 
bug.  
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: mozilla0.9 → ---

Comment 3

18 years ago
Reporter: could you specify a url where this can be reproduced?
(Reporter)

Comment 4

18 years ago
Well. I tried to figure some more details today and I came up with a little
surprise. The problem was caused by the WWWOffle daemon which sent
"CONTENT-ENCODING: x-gzip" included in every page header that came from the
proxy cache. Unfortunately it never got compressed so Mozilla was unable to
decompress the uncompressed page *g*. Unfortunately Mozilla never brought up a
error message box (like Netscape does) and just displayed nothing. Opera seems
to silently ignore the error and displays the compressed-marked uncompressed
page fine...

So actually the only bug in Mozilla is that it just doesn't report when
something went wrong during uncompressing of a page.

I've changed the bug report appropriately and sorry for the previous wrong
informations but I didn't know better and I was very confident that it was a bug
with Mozilla. :-(
Severity: major → normal
Summary: page isn't loaded/displayed until reload is being pushed → Mozilla doesn't display an error message dialog if something fails during uncompressing of a compressed page.

Updated

18 years ago
Blocks: 61685
Target Milestone: --- → mozilla1.0

Comment 5

17 years ago
Bugs targeted at mozilla1.0 without the mozilla1.0 keyword moved to mozilla1.0.1 
(you can query for this string to delete spam or retrieve the list of bugs I've 
moved)
Target Milestone: mozilla1.0 → mozilla1.0.1

Updated

17 years ago
Target Milestone: mozilla1.0.1 → Future

Comment 6

16 years ago
moving neeti's futured bugs for triaging.
Assignee: neeti → new-network-bugs
OS: Linux → All
Hardware: PC → All
Summary: Mozilla doesn't display an error message dialog if something fails during uncompressing of a compressed page. → Mozilla doesn't display an error message dialog if something fails during uncompressing of a compressed page. (gzip)

Comment 7

14 years ago
-> defaults, I think it probably works by now too.
Summary: Mozilla doesn't display an error message dialog if something fails during uncompressing of a compressed page. (gzip) → oesn't display an error message dialog if something fails during uncompressing of a compressed page. (gzip)

Updated

14 years ago
Summary: oesn't display an error message dialog if something fails during uncompressing of a compressed page. (gzip) → No error dialog if something fails during uncompressing gzip
Reporter: Will this be fixed by bug 184144 ?
(Reporter)

Comment 9

13 years ago
I currently have no way of verifying that but I guess bug #184144 will solve 
this issue too. It is definitely strongly related. 
 
I'd suggest closing this bug as a duplicate of bug #184144. 
(In reply to comment #9)
> I currently have no way of verifying that but I guess bug #184144 will solve 
> this issue too. It is definitely strongly related. 

If you can reproduce the problem, you can download a nightly build from
<http://ftp.mozilla.org/pub/mozilla.org/seamonkey/nightly/latest-trunk/> and
verify that this has been fixed (you should get an error page now).
Assignee: general → nobody
QA Contact: tever → networking.http
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.