Closed Bug 749699 Opened 8 years ago Closed 8 years ago

Viewport is corrupt, vertical scrollbars not visible

Categories

(Firefox :: Untriaged, defect, major)

x86
macOS
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 749935

People

(Reporter: frank.lymann, Unassigned)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_8) AppleWebKit/534.55.3 (KHTML, like Gecko) Version/5.1.5 Safari/534.55.3

Steps to reproduce:

We are using imagezoom as image viewer. Since Firefox 12 the screen will be broken after launching imagezoom.


Actual results:

User is unable to scroll, no scrollbars visible. Viewport switches to Position 0. I can reproduce the problem on any website! If there is an element with a negative position less than 1*e^8 the scrollbars are disappearing.


Expected results:

Tested in FF11 / Chrome / IE / Safari / Opera -> Scrollbars visible ...
Seems to be a problem to handle large negative integers ...
Severity: normal → major
try: http://www.bertramakers.com/moolabs/imagezoom.php and click on an image ...
 lightbox images are styled with: position: absolute; top: -9999999999px;
Version: 12 Branch → Trunk
We were facing the same problem. jquery-ui-1.7.2.custom.css uses for ".ui-helper-hidden-accessible" the position "left: -99999999px"

Cutting of one "9" solved it.

We got the problem with missing horizontal scroll bars with firefox 12.0. 

F11, Chrome and IE didn't have the problem.
CONFIRMED! Mozilla/5.0 (Windows NT 5.1; rv:12.0) Gecko/20100101 Firefox/12.0

FYI, there's a discussion on mozillaZine forum about this ==> http://forums.mozillazine.org/viewtopic.php?f=25&t=2469125
Status: UNCONFIRMED → NEW
Ever confirmed: true
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 749935
You need to log in before you can comment on or make changes to this bug.