Closed Bug 749719 Opened 9 years ago Closed 9 years ago

Activate accessibility mode when device a11y is enabled

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 15

People

(Reporter: eeejay, Assigned: eeejay)

References

Details

Attachments

(1 file, 1 obsolete file)

Utilize the AccessFu js module. It will check if platform accessibility is enabled, if it is it will override the d-pad keys and superimpose the virtual cursor position.
Assignee: nobody → eitan
OS: Linux → Android
Hardware: x86_64 → ARM
Target Milestone: --- → Firefox 15
I'll flag this for review soon.
Depends on: 750528
This sets the default accessibility.accessfu to 2 (auto).

And.. I think this is ready for review! I think what should be important to the reviewer is that this does not affect users who don't have a Android accessibility enabled.
Attachment #619120 - Attachment is obsolete: true
Attachment #620901 - Flags: review?(mbrubeck)
Attachment #620901 - Flags: review?(mbrubeck) → review+
https://hg.mozilla.org/mozilla-central/rev/106a74f83351
Status: NEW → RESOLVED
Closed: 9 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
It looks like this caused a regression in the Tp4 Mobile benchmark:

http://graphs.mozilla.org/graph.html#tests=[[84,63,20]]&sel=1336140433529.5078,1336318390388.1465&displayrange=7&datatype=running

Does AccessFu have any effect on the browser if it's not enabled?  (It looks like it shouldn't.)  Is there any reason it would be enabled on the Talos test slaves?
I'm having a hard time understanding the test and the result. The only thing I could think of is the accessibility check on startup. that should probably be decoupled. I thought it was on a separate thread, but it is not. Could a regression in startup time affect this test?

http://mxr.mozilla.org/mozilla-central/source/mobile/android/base/GeckoAppShell.java#1848

If you think that might make sense, I could work on that tomorrow.
We should probably move both the Prompt:Show and Accessibility:IsEnabled chunks out into their own GeckoEventResponder implementations. Any string-related operations are expensive in Java, and doing two unnecessary string creations and compares on every message probably doesn't help us.
I think the patch in bug 752935 remedies the regression.
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.