Pinch zooming inwards on Duck Duck Go shrinks page to quarter size and white out surrounding content area

VERIFIED DUPLICATE of bug 753742

Status

()

VERIFIED DUPLICATE of bug 753742
6 years ago
6 years ago

People

(Reporter: aaronmt, Assigned: cwiiis)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(blocking-fennec1.0 +)

Details

(Whiteboard: [testday-20120518])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 619133 [details]
Inbound (04/27) - Screenshot

Verifying bug 746120 and stumbled across another issue related to Duck Duck Go. Pinch-zooming inwards yields the site content to shrink to a quarter size and surrounding area is all black.

--
Samsung Galaxy Nexus (Android 4.0.4)
20120427104519
http://hg.mozilla.org/integration/mozilla-inbound/rev/717b3ea8f842
(Reporter)

Updated

6 years ago
Summary: Pinch zooming inwards on Duck Duck Go blacks out content → Pinch zooming inwards on Duck Duck Go shrinks page to quarter size and blacks out surrounding content area
(Reporter)

Comment 1

6 years ago
Still reproducible (04/30).
Assignee: nobody → chrislord.net
blocking-fennec1.0: ? → +
(Assignee)

Comment 2

6 years ago
DuckDuckGo is doing something odd with fixed position elements... It behaves better with the patches in bug 607417, but still not correct.

It'd be good to get someone with more layout knowledge to comment on this. It almost seems like we might be getting the document size wrong?

Comment 3

6 years ago
Adding in some layout team to respond to #2
I don't see any fixed-pos content on that page (unless you open one of the menus). The bottom bar is absolutely positioned.

Comment 5

6 years ago
I'm not seeing this on the latest nightly.  Perhaps bug 749425 is helping?
(Reporter)

Comment 6

6 years ago
I still see this. Black has been replaced with white though. Small steps!
Summary: Pinch zooming inwards on Duck Duck Go shrinks page to quarter size and blacks out surrounding content area → Pinch zooming inwards on Duck Duck Go shrinks page to quarter size and white out surrounding content area
(Assignee)

Comment 7

6 years ago
Marking this as a dupe of bug 753742, which has a patch that fixes this.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 753742
Verify that this bug is fixed on nightly (v15 - 18 May).

The bug still affects beta (v14.0b2)

Tested on sgs2 cyanogenmod 9 (ics)

Tested url: http://duckduckgo.com/
Whiteboard: [testday-20120518]
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.