crash in mozilla::layers::TiledLayerBufferOGL::ValidateTile

RESOLVED DUPLICATE of bug 754233

Status

()

Core
Graphics
--
critical
RESOLVED DUPLICATE of bug 754233
6 years ago
6 years ago

People

(Reporter: Scoobidiver (away), Unassigned)

Tracking

(4 keywords)

Trunk
ARM
Android
crash, mobile, regression, testcase
Points:
---

Firefox Tracking Flags

(blocking-fennec1.0 soft)

Details

(Whiteboard: [native-crash], crash signature, URL)

(Reporter)

Description

6 years ago
There's one crash in 15.0a1/20120427.

Signature 	mozilla::layers::TiledLayerBufferOGL::ValidateTile More Reports Search
UUID	8f8bd0a5-3b5d-4807-9369-e30f22120427
Date Processed	2012-04-27 18:53:00
Uptime	76
Last Crash	34.7 minutes before submission
Install Age	2.1 hours since version was first installed.
Install Time	2012-04-27 16:49:47
Product	FennecAndroid
Version	15.0a1
Build ID	20120427030500
Release Channel	nightly
OS	Linux
OS Version	0.0.0 Linux 2.6.39.4 #1 SMP PREEMPT Mon Mar 12 14:57:15 CST 2012 armv7l
Build Architecture	arm
Build Architecture Info	
Crash Reason	SIGSEGV
Crash Address	0x8
App Notes 	
EGL? EGL+ AdapterVendorID: ventana, AdapterDeviceID: Transformer TF101.
AdapterDescription: 'NVIDIA, Model: 'Transformer TF101', Product: 'WW_epad', Manufacturer: 'asus', Hardware: 'ventana''.
GL Context? GL Context+ GL Layers? GL Layers+ 
asus Transformer TF101
asus/WW_epad/TF101:4.0.3/IML74K/WW_epad-9.2.1.17-20120312:user/release-keys
EMCheckCompatibility	True

Frame 	Module 	Signature 	Source
0 	libxul.so 	mozilla::layers::TiledLayerBufferOGL::ValidateTile 	gfx/layers/opengl/TiledThebesLayerOGL.cpp:97
1 	libxul.so 	mozilla::layers::TiledLayerBufferOGL::Upload 	gfx/layers/TiledLayerBuffer.h:349
2 	libxul.so 	mozilla::layers::TiledThebesLayerOGL::ProcessUploadQueue 	gfx/layers/opengl/TiledThebesLayerOGL.cpp:167
3 	libxul.so 	mozilla::layers::TiledThebesLayerOGL::RenderLayer 	gfx/layers/opengl/TiledThebesLayerOGL.cpp:212
4 	libxul.so 	mozilla::layers::ShadowContainerLayerOGL::RenderLayer 	gfx/layers/opengl/ContainerLayerOGL.cpp:252
5 	libxul.so 	mozilla::layers::ShadowContainerLayerOGL::RenderLayer 	gfx/layers/opengl/ContainerLayerOGL.cpp:252
6 	libxul.so 	mozilla::layers::ShadowContainerLayerOGL::RenderLayer 	gfx/layers/opengl/ContainerLayerOGL.cpp:252
7 	libxul.so 	mozilla::layers::LayerManagerOGL::Render 	gfx/layers/opengl/LayerManagerOGL.cpp:828
8 	libxul.so 	mozilla::layers::LayerManagerOGL::EndTransaction 	gfx/layers/opengl/LayerManagerOGL.cpp:468
9 	libxul.so 	mozilla::layers::LayerManagerOGL::EndEmptyTransaction 	gfx/layers/opengl/LayerManagerOGL.cpp:441
10 	libxul.so 	mozilla::layers::CompositorParent::Composite 	gfx/layers/ipc/CompositorParent.cpp:254
11 	libxul.so 	RunnableMethod<mozilla::layers::CompositorParent, void , Tuple0>::Run 	ipc/chromium/src/base/tuple.h:383
12 	libxul.so 	MessageLoop::RunTask 	ipc/chromium/src/base/message_loop.cc:318
13 	libxul.so 	MessageLoop::DeferOrRunPendingTask 	ipc/chromium/src/base/message_loop.cc:326
14 	libxul.so 	MessageLoop::DoWork 	ipc/chromium/src/base/message_loop.cc:426
15 	libxul.so 	base::MessagePumpDefault::Run 	ipc/chromium/src/base/message_pump_default.cc:23
16 	libxul.so 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:208
17 	libxul.so 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:201
18 	libxul.so 	base::Thread::ThreadMain 	ipc/chromium/src/base/thread.cc:156
19 	libxul.so 	ThreadFunc 	ipc/chromium/src/base/platform_thread_posix.cc:26
20 	libc.so 	libc.so@0x12e2e 	
21 	libc.so 	libc.so@0x12982 	

More reports at:
https://crash-stats.mozilla.com/report/list?signature=mozilla%3A%3Alayers%3A%3ATiledLayerBufferOGL%3A%3AValidateTile
I can reproduce this on the Samsung Galaxy Nexus with: http://people.mozilla.org/~mwargers/tests/panning/iframe_fullpage_panning.html
Steps to reproduce:
- Zoom in completely, then do some panning

We should see if this is a regression and if we can find a regression range here.
blocking-fennec1.0: --- → ?
Keywords: mobile, regressionwindow-wanted, testcase
Version: 15 Branch → Trunk
This certainly wont happen before bug 739679 landed.
Blocks: 739679
(Reporter)

Updated

6 years ago
Keywords: regressionwindow-wanted → regression
blocking-fennec1.0: ? → soft
This is the same signature I've seen in the debugger while working on bug 754233.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 754233
You need to log in before you can comment on or make changes to this bug.