Last Comment Bug 749788 - Various errors exist in JNI code
: Various errors exist in JNI code
Status: RESOLVED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: All Android
: -- normal (vote)
: Firefox 15
Assigned To: Kartikaya Gupta (email:kats@mozilla.com)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-27 14:02 PDT by Kartikaya Gupta (email:kats@mozilla.com)
Modified: 2012-05-15 12:37 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed
+


Attachments
Patch (5.29 KB, patch)
2012-04-27 14:02 PDT, Kartikaya Gupta (email:kats@mozilla.com)
blassey.bugs: review+
blassey.bugs: approval‑mozilla‑aurora+
Details | Diff | Review

Description Kartikaya Gupta (email:kats@mozilla.com) 2012-04-27 14:02:27 PDT
Created attachment 619165 [details] [diff] [review]
Patch

Various errors I found: missing null checks and potentially using the wrong JNIEnv for the thread. Also a bad variable initialization.
Comment 1 Kartikaya Gupta (email:kats@mozilla.com) 2012-04-28 09:58:38 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/2d619155c69b

Half of the patch was rendered unnecessary by snorp's patch from bug 727116 so this only has the other half.
Comment 2 Ryan VanderMeulen [:RyanVM] 2012-04-29 15:57:54 PDT
http://hg.mozilla.org/mozilla-central/rev/2d619155c69b
Comment 3 Kartikaya Gupta (email:kats@mozilla.com) 2012-04-30 07:13:22 PDT
Comment on attachment 619165 [details] [diff] [review]
Patch

[Approval Request Comment]
Regression caused by (bug #): various
User impact if declined: future patches (flash-related) may not apply cleanly
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): not much risk, mobile-only
String changes made by this patch: none
Comment 4 Alex Keybl [:akeybl] 2012-04-30 10:36:49 PDT
Let's find out if this is blocking fennec 1.0 before approving for Aurora 14. My intuition tells me it's not a blocker, but still OK to take. I'd like clarification though.
Comment 5 Kartikaya Gupta (email:kats@mozilla.com) 2012-05-07 07:35:44 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/5dc031d43ff3
Comment 6 Brad Lassey [:blassey] (use needinfo?) 2012-05-12 07:18:16 PDT
*** Bug 694992 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.