Last Comment Bug 749795 - Getter for NPNVprivateModeBool is broken with OOPP
: Getter for NPNVprivateModeBool is broken with OOPP
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: mozilla15
Assigned To: Josh Matthews [:jdm]
:
Mentors:
Depends on:
Blocks: PBnGen 748752
  Show dependency treegraph
 
Reported: 2012-04-27 14:13 PDT by Josh Matthews [:jdm]
Modified: 2012-05-02 21:08 PDT (History)
3 users (show)
josh: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Use neglected code that properly obtains private browsing mode in plugins. (3.53 KB, patch)
2012-04-30 00:46 PDT, Josh Matthews [:jdm]
jaas: review+
Details | Diff | Review

Description Josh Matthews [:jdm] 2012-04-27 14:13:26 PDT
I'm glad I decided to add a test for bug 748752, since it exposed that the code is completely broken. Retrieving the document (http://mxr.mozilla.org/mozilla-central/source/dom/plugins/base/nsNPAPIPlugin.cpp#2139) fails, since npp is null (http://mxr.mozilla.org/mozilla-central/source/dom/plugins/ipc/PluginModuleParent.cpp#978). Josh, what's the correct way to fix this?
Comment 1 Josh Matthews [:jdm] 2012-04-27 14:58:17 PDT
It looks like the privateModeBool handling will need to move to PluginInstance*, similar to pluginElementNPObject and pluginWindowNPObject.
Comment 2 Josh Matthews [:jdm] 2012-04-30 00:46:52 PDT
Created attachment 619505 [details] [diff] [review]
Use neglected code that properly obtains private browsing mode in plugins.

That was easy. The test now passes.
Comment 3 Josh Aas 2012-04-30 06:58:58 PDT
Comment on attachment 619505 [details] [diff] [review]
Use neglected code that properly obtains private browsing mode in plugins.

Review of attachment 619505 [details] [diff] [review]:
-----------------------------------------------------------------

Did you intend to include the change to test_domstorage_aboutpages.js?
Comment 4 Josh Matthews [:jdm] 2012-04-30 09:21:31 PDT
Nein. I'll take that out when landing.
Comment 6 :Ehsan Akhgari (out sick) 2012-05-02 21:08:15 PDT
https://hg.mozilla.org/mozilla-central/rev/52abbd73ec2d

Note You need to log in before you can comment on or make changes to this bug.