Last Comment Bug 749933 - Build error with gcc-4.7 after Bug 745057 fixed
: Build error with gcc-4.7 after Bug 745057 fixed
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: mozilla15
Assigned To: general
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on:
Blocks: 745057
  Show dependency treegraph
 
Reported: 2012-04-28 05:13 PDT by ojab
Modified: 2012-05-04 09:34 PDT (History)
4 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description ojab 2012-04-28 05:13:39 PDT
mozilla-inbound r92648:1ed9525b2a9f builds fine, following error on r92650:75b367f73319

c++ -o Stack.o -c  -I./../../dist/system_wrappers_js -include /sources/mozilla-inbound/config/gcc_hidden.h -DMOZ_GLUE_IN_PROGRAM -DEXPORT_JS_API -DJS_HAS_CTYPES -DDLL_PREFIX=\"lib\" -DDLL_SUFFIX=\".so\" -DNO_NSPR_10_SUPPORT -I/usr/lib/libffi-3.0.10/include   -I.  -I/sources/mozilla-inbound/js/src/../../mfbt/double-conversion -I/sources/mozilla-inbound/js/src -I. -I./../../dist/include -I./../../dist/include/nsprpub  -I/home/ojab/opt/xulrunner/dist/include/nspr  -I/sources/mozilla-inbound/js/src -I/sources/mozilla-inbound/js/src/assembler -I/sources/mozilla-inbound/js/src/yarr  -fPIC  -fno-rtti -pedantic -Wall -Wpointer-arith -Woverloaded-virtual -Werror=return-type -Wtype-limits -Wempty-body -Wno-ctor-dtor-privacy -Wno-overlength-strings -Wno-invalid-offsetof -Wno-variadic-macros -Wcast-align -Wno-long-long -ffunction-sections -fdata-sections -pthread -pipe  -DNDEBUG -DTRIMMED -g -O3 -freorder-blocks  -fomit-frame-pointer -DUSE_SYSTEM_MALLOC=1 -DENABLE_ASSEMBLER=1 -DENABLE_JIT=1   -DMOZILLA_CLIENT -include ./js-confdefs.h -MD -MF .deps/Stack.pp /sources/mozilla-inbound/js/src/vm/Stack.cpp
In file included from /sources/mozilla-inbound/js/src/jsobj.h:52:0,
                 from /sources/mozilla-inbound/js/src/jsscope.h:51,
                 from /sources/mozilla-inbound/js/src/vm/ObjectImpl.cpp:11:
/sources/mozilla-inbound/js/src/jsapi.h: In instantiation of ‘static JS::Value JS::detail::MakeNumberValue<false>::create(T) [with T = js::uint8_clamped]’:
/sources/mozilla-inbound/js/src/jsapi.h:803:80:   required from ‘JS::Value JS::NumberValue(T) [with T = js::uint8_clamped]’
/sources/mozilla-inbound/js/src/vm/ObjectImpl.cpp:335:5:   required from ‘bool js::TypedElementsHeader<T>::getOwnElement(JSContext*, js::ObjectImpl*, uint32_t, js::PropDesc*) [with T = js::uint8_clamped; JSContext = JSContext; uint32_t = unsigned int]’
/sources/mozilla-inbound/js/src/vm/ObjectImpl.cpp:495:82:   required from here
/sources/mozilla-inbound/js/src/jsapi.h:788:9: warning: comparison is always true due to limited range of data type [-Wtype-limits]
/sources/mozilla-inbound/js/src/vm/Stack.cpp: In member function ‘JS::Value js::StackIter::thisv() const’:
/sources/mozilla-inbound/js/src/vm/Stack.cpp:1355:1: error: control reaches end of non-void function [-Werror=return-type]
cc1plus: some warnings being treated as errors
make[6]: *** [Stack.o] Error 1
Comment 1 Jeff Walden [:Waldo] (remove +bmo to email) 2012-04-28 07:10:03 PDT
Hmm, there are two warnings here.  The first one looks like me, bug 739380.  Second's probably the dep you've tagged.  I'll look into the first shortly...
Comment 2 Jeff Walden [:Waldo] (remove +bmo to email) 2012-04-28 10:22:41 PDT
I fixed both warnings in this change:

https://hg.mozilla.org/integration/mozilla-inbound/rev/27d42a3feef1
Comment 3 ojab 2012-04-28 11:02:48 PDT
r92672:299758765c72 build fine.
Comment 4 :Ms2ger (⌚ UTC+1/+2) 2012-04-29 13:06:16 PDT
    2.18 +template<>
    2.19 +/* static */ Value
    2.20 +ElementToValue(const uint8_clamped u)

Did you miss an &?
Comment 5 Ryan VanderMeulen [:RyanVM] 2012-04-29 15:59:02 PDT
http://hg.mozilla.org/mozilla-central/rev/27d42a3feef1

Leaving open pending comment 4.
Comment 6 Ed Morley [:emorley] 2012-05-04 09:32:29 PDT
https://hg.mozilla.org/mozilla-central/rev/8fdb1a8ecde0

> Leaving open pending comment 4.

Waldo?
Comment 7 Ed Morley [:emorley] 2012-05-04 09:34:43 PDT
Oops, sorry read comment 5 as the inbound half of the 8fdb1a8ecde0 commit, whereas that was a different cset.

All done here.

Note You need to log in before you can comment on or make changes to this bug.