Last Comment Bug 749951 - In member function ‘JS::Value js::StackIter::thisv() const’: error: control reaches end of non-void function [-Werror=return-type]
: In member function ‘JS::Value js::StackIter::thisv() const’: error: control r...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: mozilla15
Assigned To: general
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-28 07:44 PDT by Mats Palmgren (vacation)
Modified: 2012-04-29 15:59 PDT (History)
2 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Mats Palmgren (vacation) 2012-04-28 07:44:18 PDT
Linux64 debug build of mozilla-inbound rev f2c2a457f9cc:

In member function ‘JS::Value js::StackIter::thisv() const’: error: control reaches end of non-void function [-Werror=return-type]

# gcc --version
gcc (Ubuntu/Linaro 4.6.1-9ubuntu3) 4.6.1
Comment 1 Jeff Walden [:Waldo] (remove +bmo to email) 2012-04-28 10:22:31 PDT
Fixed here:

https://hg.mozilla.org/integration/mozilla-inbound/rev/27d42a3feef1
Comment 2 Mats Palmgren (vacation) 2012-04-28 10:48:04 PDT
OK, it works for me now, thanks!
Comment 3 Ryan VanderMeulen [:RyanVM] 2012-04-29 15:59:26 PDT
http://hg.mozilla.org/mozilla-central/rev/27d42a3feef1

Note You need to log in before you can comment on or make changes to this bug.