Last Comment Bug 749976 - Reduce the curve tolerance to match skia on mobile
: Reduce the curve tolerance to match skia on mobile
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla15
Assigned To: Jeff Muizelaar [:jrmuizel]
:
: Milan Sreckovic [:milan]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-28 13:29 PDT by Jeff Muizelaar [:jrmuizel]
Modified: 2012-06-01 15:00 PDT (History)
5 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-


Attachments
Use a value of 0.4 (1.29 KB, patch)
2012-04-28 13:34 PDT, Jeff Muizelaar [:jrmuizel]
no flags Details | Diff | Splinter Review
Use a value of 0.2 (1.02 KB, patch)
2012-05-23 21:45 PDT, Jeff Muizelaar [:jrmuizel]
b56girard: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Jeff Muizelaar [:jrmuizel] 2012-04-28 13:29:25 PDT
Skia uses a value of 0.5
Comment 1 Jeff Muizelaar [:jrmuizel] 2012-04-28 13:34:18 PDT
Created attachment 619335 [details] [diff] [review]
Use a value of 0.4
Comment 2 Jeff Muizelaar [:jrmuizel] 2012-05-23 21:45:41 PDT
Created attachment 626693 [details] [diff] [review]
Use a value of 0.2

0.4 was causing small reftest failures. This is doesn't cause the failures and should still improve performance.
Comment 3 Jeff Muizelaar [:jrmuizel] 2012-05-24 21:18:40 PDT
Looks like there were still reftest failures:
https://hg.mozilla.org/integration/mozilla-inbound/rev/9713cb1ed642
Comment 4 Jeff Muizelaar [:jrmuizel] 2012-05-24 21:19:22 PDT
Here's the original landing:
https://hg.mozilla.org/integration/mozilla-inbound/rev/50178ba811f2
Comment 5 Jeff Muizelaar [:jrmuizel] 2012-05-25 14:52:40 PDT
Try again:
https://hg.mozilla.org/integration/mozilla-inbound/rev/2e882879c853
Comment 6 Ryan VanderMeulen [:RyanVM] 2012-05-26 05:30:19 PDT
https://hg.mozilla.org/mozilla-central/rev/2e882879c853
Comment 7 Jeff Muizelaar [:jrmuizel] 2012-05-28 21:45:09 PDT
Comment on attachment 626693 [details] [diff] [review]
Use a value of 0.2

[Approval Request Comment]
User impact if declined: Slower curve drawing performance. The spinning svg tiger goes from 6.5fps to 7.5fps on my phone
Testing completed (on m-c, etc.): Has been on m-c for a couple of days
Risk to taking this patch (and alternatives if risky): Mobile only, very low risk as it's just changing a constant.
String or UUID changes made by this patch: None
Comment 8 Alex Keybl [:akeybl] 2012-06-01 15:00:16 PDT
Comment on attachment 626693 [details] [diff] [review]
Use a value of 0.2

[Triage Comment]
While this doesn't block release, the risk profile is low enough (and SVG usage uncommon enough) to take this on Aurora 14. Approved.

Note You need to log in before you can comment on or make changes to this bug.