Closed Bug 75004 Opened 19 years ago Closed 19 years ago

Bidi: Characters in Unicode UTF-8 are displayed reversed on US system

Categories

(Core :: Internationalization, defect)

x86
Windows 98
defect
Not set

Tracking

()

VERIFIED INVALID
mozilla0.9.1

People

(Reporter: mrous, Assigned: ftang)

Details

Attachments

(1 file)

From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows 98)
BuildID:    00000000 - Bidi build dated 20010404

Unicode Arabic text is displayed reversed on a US system


Reproducible: Always
Steps to Reproduce:
1.Open file ken.htm


Actual Results:  Arabic text is displayed reversed

Expected Results:  Arabic text should be displayed as with IE5
we are focusing on landing IBMBIDI without breaking CJK and Latin. Move bidi 
functional bugs to moz0.9.1
Target Milestone: --- → mozilla0.9.1
The Arabic Hebrew and Farsi text in this example are in visual order (which is
incorrect for UTF-8) so Mozilla's behaviour here is correct.

On selecting Bidi Options | Text Type | Visual, the text is displayed as expected.

The Arabic and Farsi are displayed correctly in IE5 because two errors are
cancelling one another out: the visual order and the fact that IE5 doesn't
classify Bidi characters in the FExx range as right-to-left. Note that the
Hebrew text is displayed reversed in IE5 and AFAIK there is no way in the UI to
correct this.
erik resign. reassign all his bug to ftang for now.
Assignee: erik → ftang
according to simon. mark this bug as invalid
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → INVALID
Verifying as invalid according to Simon's comment. Please reopen in case someone 
disagrees.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.