Provide Toolbars animation

RESOLVED DUPLICATE of bug 867317

Status

()

Firefox
Toolbars and Customization
--
enhancement
RESOLVED DUPLICATE of bug 867317
5 years ago
3 years ago

People

(Reporter: ge3k0s, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
The bookmark bar, the find bar and the other toolbars should be animated. A smooth animation with bars appearing from up to down would improve discoverability and visual experience. Other browsers already do it.

Updated

5 years ago
Severity: normal → enhancement
Summary: Toolbars animation → Provide Toolbars animation
(Reporter)

Updated

5 years ago
Keywords: uiwanted
(Reporter)

Updated

5 years ago
Blocks: 565552

Updated

5 years ago
No longer blocks: 565552

Comment 1

5 years ago
Other browsers (at least Safari) also make make sure that the page does not shift down or move even a little bit as the new toolbar lowers into place. This is bug 248715. Could that be added as a dependency?

Comment 2

5 years ago
FWIW, this is planned: https://wiki.mozilla.org/Firefox/Features/UI_animations

I took a look at it but wasn't able to get it working. Maybe someone else can or I'll take another look.
(Reporter)

Updated

5 years ago
Depends on: 248715
(Reporter)

Comment 3

5 years ago
@David Regev : The problem with Safari implementation is that the content on the top of the page is hidden by the toolbar and for example for the search bar it hides content that could be searched. If the searched phrase is under it the page will be automatically scrolled up and it doesn't fell right.

Comment 4

5 years ago
Guillaume: I’m not sure I understand the exact issue you’re describing. But surely this can be solved? Whatever the issue, having the page shift down every time you bring up the Find bar (and back up when the bar is dismissed) is not a usable experience. The same goes for all other toolbars.
(Reporter)

Comment 5

5 years ago
(In reply to Chris Lee (:cleer) from comment #2)
> FWIW, this is planned:
> https://wiki.mozilla.org/Firefox/Features/UI_animations
> 
> I took a look at it but wasn't able to get it working. Maybe someone else
> can or I'll take another look.

Some news about this. 

IMO all bars should be animated.
(Reporter)

Updated

5 years ago
Depends on: 836867
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: meta
Depends on: 867317
(Reporter)

Updated

4 years ago
Blocks: 950073

Updated

4 years ago
Whiteboard: p=0

Updated

4 years ago
Whiteboard: p=0 → [tracking]

Updated

3 years ago
No longer blocks: 950073
Toolbars is bug 867317, the find bar is bug 836867.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
No longer depends on: 248715, 867317, 836867
Keywords: meta, uiwanted
Resolution: --- → DUPLICATE
Whiteboard: [tracking]
Duplicate of bug: 867317
You need to log in before you can comment on or make changes to this bug.