Intermittent test_bug708620.html | Not the right error message - got [ Places Maintenance ] or [ WARN addons.updates ] or [ Could be meat, could be cake ]

RESOLVED FIXED in Firefox 16

Status

()

Core
HTML: Form Submission
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: emorley, Assigned: emk)

Tracking

({intermittent-failure})

15 Branch
mozilla17
x86_64
Linux
intermittent-failure
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox16 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Rev3 Fedora 12x64 mozilla-inbound debug test mochitests-1/5 on 2012-04-30 04:45:11 PDT for push f99cf2f41355

slave: talos-r3-fed64-053

https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=f99cf2f41355
https://tbpl.mozilla.org/php/getParsedLog.php?id=11322015&tree=Mozilla-Inbound

{
WARNING: 1 sort operation has occurred for the SQL statement '0x7f31d0048b58'.  See https://developer.mozilla.org/En/Storage/Warnings details.: file /builds/slave/m-in-lnx64-dbg/build/storage/src/mozStoragePrivateHelpers.cpp, line 144
WARNING: Subdocument container has no frame: file /builds/slave/m-in-lnx64-dbg/build/layout/base/nsDocumentViewer.cpp, line 2443
++DOMWINDOW == 45 (0x5467318) [serial = 892] [outer = 0x6479bb0]
WARNING: 1 sort operation has occurred for the SQL statement '0x7f31d009ee68'.  See https://developer.mozilla.org/En/Storage/Warnings details.: file /builds/slave/m-in-lnx64-dbg/build/storage/src/mozStoragePrivateHelpers.cpp, line 144
WARNING: 1 sort operation has occurred for the SQL statement '0x7f31d009ecd8'.  See https://developer.mozilla.org/En/Storage/Warnings details.: file /builds/slave/m-in-lnx64-dbg/build/storage/src/mozStoragePrivateHelpers.cpp, line 144
34683 INFO TEST-PASS | /tests/content/base/test/test_bug708620.html | Not the right error message - [JavaScript Warning: "A form was submitted in the windows-1252 encoding which cannot encode all Unicode characters, so user input may get corrupted. To avoid this problem, the page should be changed so that the form is submitted in the UTF-8 encoding either by changing the encoding of the page itself to UTF-8 or by specifying accept-charset=utf-8 on the form element." {file: "http://mochi.test:8888/tests/content/base/test/file_bug708620.html" line: 1}] should equal [JavaScript Warning: "A form was submitted in the windows-1252 encoding which cannot encode all Unicode characters, so user input may get corrupted. To avoid this problem, the page should be changed so that the form is submitted in the UTF-8 encoding either by changing the encoding of the page itself to UTF-8 or by specifying accept-charset=utf-8 on the form element." {file: "http://mochi.test:8888/tests/content/base/test/file_bug708620.html" line: 1}]
34684 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug708620.html | Not the right error message - got [ Places Maintenance ]
> Integrity check
+ The database is sane
> Coherence check
+ The database is coherent, expected undefined
WARNING: Subdocument container has no frame: file /builds/slave/m-in-lnx64-dbg/build/layout/base/nsDocumentViewer.cpp, line 2443
++DOMWINDOW == 46 (0x731a708) [serial = 893] [outer = 0x6479bb0]
34685 INFO TEST-PASS | /tests/content/base/test/test_bug708620.html | The error supply was not exhausted - 0 should equal 0
34686 INFO TEST-END | /tests/content/base/test/test_bug708620.html | finished in 1768ms
}
Comment hidden (Treeherder Robot)
Summary: Intermittent test_bug708620.html | Not the right error message - got [ Places Maintenance ] → Intermittent test_bug708620.html | Not the right error message - got [ Places Maintenance ] or [ WARN addons.updates ] or [ Could be meat, could be cake ]
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Depends on: 751813
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 107

5 years ago
Created attachment 646813 [details] [diff] [review]
Filter console messages
Attachment #646813 - Flags: review?(hsivonen)
Comment hidden (Treeherder Robot)
Comment on attachment 646813 [details] [diff] [review]
Filter console messages

>+        } catch (e) { }
>+        this.userListener(consoleMessage.message, fileName);

Please indent the "this." line by two more spaces. r=hsivonen with the indent fixed.
Attachment #646813 - Flags: review?(hsivonen) → review+
(Assignee)

Comment 110

5 years ago
Created attachment 647124 [details] [diff] [review]
Filter console messages. r=hsivonen

I moved the right brace to avoid misreading the indent.
Attachment #647124 - Flags: review+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
(Assignee)

Updated

5 years ago
Attachment #646813 - Attachment is obsolete: true
https://hg.mozilla.org/integration/mozilla-inbound/rev/f460d14064fc
Assignee: nobody → VYV03354
Status: NEW → ASSIGNED
Keywords: checkin-needed
Target Milestone: --- → mozilla17
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
https://hg.mozilla.org/mozilla-central/rev/f460d14064fc
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Comment hidden (Treeherder Robot)
Would this be ok to backport to aurora? :-)
status-firefox16: --- → affected
(Assignee)

Comment 117

5 years ago
Comment on attachment 647124 [details] [diff] [review]
Filter console messages. r=hsivonen

This patch applies to aurora cleanly.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 708620
User impact if declined: None (test only)
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): None (test only)
String or UUID changes made by this patch: None (test only)
Attachment #647124 - Flags: approval-mozilla-aurora?
Comment hidden (Treeherder Robot)
Comment on attachment 647124 [details] [diff] [review]
Filter console messages. r=hsivonen

test only, approving
Attachment #647124 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
Whiteboard: [orange] → [orange][land to aurora]
https://hg.mozilla.org/releases/mozilla-aurora/rev/5ac86e22641a
status-firefox16: affected → fixed
Keywords: checkin-needed
Whiteboard: [orange][land to aurora] → [orange]
Keywords: intermittent-failure
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.