Closed Bug 750323 Opened 9 years ago Closed 9 years ago

Scroll bar disappeared in LimeSurvey

Categories

(Core :: CSS Parsing and Computation, defect)

12 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: Caseyy, Unassigned)

References

Details

Attachments

(2 files)

67.85 KB, image/gif
Details
6.23 KB, application/octet-stream
Details
Attached image limesurvey-bug.gif
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0) Gecko/20100101 Firefox/12.0
Build ID: 20120420145725

Steps to reproduce:

This issue did not exist until I upgraded from FF 11 to FF 12. Using the LimeSurvey admin area, I clicked to edit a question.


Actual results:

The question edit area is at the bottom of the screen and the scroll bar to view the question is not there.


Expected results:

Usually there is a scroll bar to view the entire page.
I reported this yesterday here:

https://bugzilla.mozilla.org/show_bug.cgi?id=750166

Title is:
Can not scroll with touchpad or keyboard in LimeSurvey Responses & Statistics page
Attached file reduced testcase
testcase.zip contains
limesurvey_admin.php.htm
jquery-ui.css
just copy both in a directory, open htm file and resize window to a size where a scrollbar should appear on right side
I can confirm the described problem with limesurvey. It renders Limesurvey on Firefox useless in my eyes since it appears in a lot of different screens.
I've attached a "reduced" testcase which should reproduce the problem from limesurvey token management.

When I remove either line
<link rel="stylesheet" type="text/css" media="all" href="jquery-ui.css">
or
<div id="ui-datepicker-div" class="ui-datepicker ui-widget ui-widget-content ui-helper-clearfix ui-corner-all ui-helper-hidden-accessible"></div>
from  the htm file of the testcase the problem disappears and the scrollbar on the right side reappears again.

I noticed this bug from FF12b2 or b3 , not sure exactly. It is still valid for FF13b2 which I use currently
See Limesurvey bugtracker bugs.limesurvey.org , bug 6045. 
There, it is said that it seems to be some problem with (old) jquery + Firefox.
Bug is closed in limesurvey bugtracker, so latest limesurvey build should include a fix for this
Component: Untriaged → Style System (CSS)
Product: Firefox → Core
QA Contact: untriaged → style-system
Mats, this looks like yet another overflow area issue in Fx12?
In particular, sounds similar to bug 754247?
Is this bug about a missing scrollbar in jQuery date picker?
If so, it's been fixed in Fx13 and later by bug 749935.
Please verify that LimeSurvey works with Fx13 beta builds:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2012-05-25-mozilla-beta-debug/
For me the issue is gone with FF13 final, seems to be fixed and could be closed
Probably fixed by bug 749935.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Depends on: 749935
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.