Upon finding a PDF file by Google search, FIREFOX no longer opens the file when I click on it.

RESOLVED DUPLICATE of bug 747073

Status

()

Firefox
Downloads Panel
RESOLVED DUPLICATE of bug 747073
6 years ago
6 years ago

People

(Reporter: skeptiker, Unassigned)

Tracking

13 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Upon finding a PDF file by Google search, FIREFOX no longer opens the file when I click on it.  This used to be one of the main reasons for preferring FIREFOX, the ease of opening and saving PDF files, of which I need many for reserach. Now, that this fails on the latest beta, I copy the URL to SAFARI, and then open and save the PDF.

Comment 1

6 years ago
- what version of Firefox are you using, and on what operating system ?
- what is the version of your PDF software (Adobe Reader or Adobe Acrobat probably) ?
- what is the setting of Options->Applications for PDF documents (it will probably be listed under the name found above) ?
if you can find this setting, does changing it helps you ?
(Reporter)

Comment 2

6 years ago
Look, when filing this bug, I already answered your questions:  

Latest Firefox 13.0b1, Mac OS-X 10.6.0, Intel dual core.  

The trouble is recent, earlier versions immediately opened download when answered "save."
Now just a blank screen. 

Still no trouble on safari, only firefox beta 13.0.  

OK?

Comment 3

6 years ago
That is only the first question - what about the 2 other ones ? Especially the one from Options->Applications : that EXACTLY determines what should happen with a download, barring any problems with the PDF reader itself. Firefox 14 might contain a built-in PDF reader btw, but it's not yet in your version.
(Reporter)

Comment 4

6 years ago
My knowledge of computers and of FIREFOX is insufficient for answering you in full.  But you really should not need my answers.  The facts are clear, on previous versions of FIREFOX, no issue ever arose.  Here is what happened then and should happen now, as best as I can remember, there may be gaps in my memory.  Perhaps you could just try an older version for yourself?

Step 1:  In the Google search, click on the title, billed as a PDF, that you would like to save to your machine.  An important 2nd case is when reading email about articles in PNAS and clicking on a title.  The abstract appears in FIREFOX. Then I link it to my university library, enter a password, and a new page appears where I can click as on the Google search page.  From there, the rest goes same as below.

Step 2:  A window appeared which ask if I want the file opened in Adobe Reader, I click on yes.  Perhaps the question was different, and perhaps there were options.  I forgot.

Step 3:  The Adobe Reader opens the file, I can read it.  If intereested, I can go to the FILE menu on the top bar on my iMac, click on SAVE as PDF, and save it in n folder.

Best of luck!
(Reporter)

Comment 5

6 years ago
ADDENDA:  In the process at one point a SMALL window opens that shows the DOWNLOAD process.  The file is saved to the DOWNLOAD folder on my iMac, and also opened in the ADOBE READER. If you don't have an ADOBE READER, not sure what happens then. When the moving bar on the SMALL window shows completion of DOWNLOAD, you can clear and/or delete that small download window.
(Reporter)

Comment 6

6 years ago
ADDENDA:  Oh yes!  I now recall there is a difference on first and later calls for opening.  The window asks "OPEN WITH" and leaves a blank window for choosing an APPLICATION file.  Of course I choose ADOBE READER. Then, on 2nd and later calls, the OPEN WITH window shows Adobe Reader by AUTOFILL, so I don't have to look in the APPLICATION folder anymore.
(Reporter)

Comment 7

6 years ago
UNSOLICITED ADVICE:  <i>Firefox 14 might contain a built-in PDF reader btw, but it's not yet in your version.</i> 

Why would Mozilla want to  create a PDF reader in version 14 --   Obviously Adobe was and is the premier reader.  BTW Safari has a buit-in PDF reader but I only use it for download.

Comment 8

6 years ago
Since you still haven't mentioned what software you have been using, I assume that it's bug 747073.

see http://blog.mozilla.org/addons/2012/05/04/adobe-reader-blocked-mac/
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 747073
(Reporter)

Comment 9

6 years ago
Not sure what you are asking:  Software?  Mozilla Firefox and Adobe Reader are only software products that I can think of, besides OS-X 10.6 of course, which I did mention.  What other software are you asking about??  Please clarify!!
(Reporter)

Comment 10

6 years ago
Fixed problem, remove adobe plug-in, firefox installed update adobe flash player  automatically.  Used advice from web very helpful page: 

        http://www.mozilla.org/en-US/plugincheck/
You need to log in before you can comment on or make changes to this bug.