Status

()

defect
RESOLVED FIXED
7 years ago
3 years ago

People

(Reporter: johan.charlez, Assigned: johan.charlez)

Tracking

(Blocks 1 bug)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Assignee

Description

7 years ago
It has been suggested that the scope bar in the library should be removed.
In addition, the "Save" button and the ability to save searches should be removed.

Furthermore, and this is not within the scope of this bug: the currently saved searches; "Most visited", "Recently Bookmarked" and "Recent Tags" should be updated to be built-in queries rather than preloaded saved searches.
Assignee

Updated

7 years ago
Assignee: nobody → johan.charlez
(In reply to Johan Charlez from comment #0)
> Furthermore, and this is not within the scope of this bug: the currently
> saved searches; "Most visited", "Recently Bookmarked" and "Recent Tags"
> should be updated to be built-in queries rather than preloaded saved
> searches.

not sure what this means, I don't see anything wrong with how they are handled now.
Assignee

Comment 2

7 years ago
(In reply to Marco Bonardo [:mak] from comment #1)
> (In reply to Johan Charlez from comment #0)
> > Furthermore, and this is not within the scope of this bug: the currently
> > saved searches; "Most visited", "Recently Bookmarked" and "Recent Tags"
> > should be updated to be built-in queries rather than preloaded saved
> > searches.
> 
> not sure what this means, I don't see anything wrong with how they are
> handled now.

I think the idea was to stop users from accidentally deleting these, with no way of getting them back?
The possibility is just hidden in prefs, I don't think we want to add UI as of now, and it's not a regression even removing the scope bar.
There are add-ons making a better work than us in building custom queries today, we may eventually re-evaluate a better "advanced search" feature in future, than just supporting some queries.
Assignee

Updated

7 years ago
Status: NEW → ASSIGNED
Assignee

Updated

7 years ago
Version: unspecified → Trunk
Assignee

Comment 4

7 years ago
Posted patch patch 0.1 wip (obsolete) — Splinter Review
Attachment #639167 - Flags: feedback?(mano)
Assignee

Updated

7 years ago
Depends on: 434156
Hey, sorry for the delay, I forgot about this other queue.., feedback. :)

Any reason you asked for feedback rather than review? This seems pretty complete.
Assignee

Comment 6

7 years ago
(In reply to Mano from comment #5)
> Hey, sorry for the delay, I forgot about this other queue.., feedback. :)
> 
> Any reason you asked for feedback rather than review? This seems pretty
> complete.

Don't worry.

I asked for feedback because I wasn't sure if I had removed enough, or possibly too much. I seem to have forgotten to specify, sorry about that.
Assignee

Updated

7 years ago
Attachment #639167 - Flags: feedback?(mano) → review?(mano)
Assignee

Comment 7

7 years ago
rebased 20120921 21:13
Attachment #639167 - Attachment is obsolete: true
Attachment #639167 - Flags: review?(mano)
Attachment #663505 - Flags: review?(mano)
Comment on attachment 663505 [details] [diff] [review]
patch 0.1 rebased 20120921

r=mano
Attachment #663505 - Flags: review?(mano) → review+
https://hg.mozilla.org/mozilla-central/rev/a2a201dd7a85
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED

Comment 10

7 years ago
Was cleaning up my bookmarks, and stumbled upon this bug.

Why was this feature removed? It's not possible to only search specific folders anymore. Let's say I want to do a search, but not in folder A, but only in folder B.

How would i restrict my search to searching in folder B without having a scope bar to restrict my search? True, I didn't use the save feature, but I've used the scope bar extensively for several years.
We are simplifying the design to port the Library in a tab, that is needed for various other changes to the product. Features may be added back once that process is complete. Currently it's not possible to restrict a search to a single folder, without using add-ons.

Comment 12

6 years ago
I agree completely with rctgamer3, the scope search is a crucial feature. 

It shouldn't be lumped in with saved searches, and it needs to be brought back ASAP. I did not find any add-ons which perform this function which I use regularly.

I'll add that opening the library in a tab strikes me as completely useless.
Feature removals have a cost, but are not done lightly, we must do them to allow us to move a bit faster on the code, that in the end allows us to reintroduce those features in a better fashion.  We plan to add a better search functionality in future, but if the code is unmaintainable that future is far far away.  Once the Library is in content we have plenty of space for redesign of a better search UI.

Updated

6 years ago

Comment 14

6 years ago
I installed FF19.0, & went to search through my bookmarks in the library (currently about 12,000) which I do many times every day...
..& when I tried to narrow down the search to current folder (& its subfolders)...
...that facility/feature aka "scope bar" is MISSING...

This creates a Huge problem for me, & it Greatly lowers the value of the search facility....
This is a CRUCIAL & ESSENTIAL feature. 

When will this feature/facility be reinstated?
PLEASE, it should be added back ASAP/URGENTLY.

Thank You,
Roberta

Comment 15

6 years ago
no no no no no no no no no. 

Get this feature BACK in ASAP.

Firefox Library/Bookmarks is the BEST, because of this feature. In fact, its the primary reason i use Firefox, so don't play games with it.

IE and Chrome bookmarks are totally useless.

I have over 20,000 bookmarks ... you honestly think i want hundreds of results for searches that should be confined to a folder and it's sub-folders? No. This makes FF 19 useless. Filter made searching and managing bookmarks very efficient.

Comment 16

6 years ago
> "we must do them to allow us to move a bit faster on the code, that 
> in the end allows us to reintroduce those features in a better fashion"

Do not remove this feature. Do a backflip if you have to, but keep it in until you have your replacement search/filter in place. 

I will downgrade to FF 18 if this is the case.

Comment 17

6 years ago
I created an account just to voice my disappointment with this.  It's nice to see I'm not alone here.  The filter search feature is extremely important and its loss really is a deal-breaker for me.  I'll be using a different version of FF until it gets reinstated (and if it takes too long, i.e. I miss out on necessary patches and the like, I'll just stop using FF altogether.)

This move makes absolutely no sense to me.  I'll especially agree with Daniel Xavier: "the scope search is a crucial feature. It shouldn't be lumped in with saved searches, and it needs to be brought back ASAP. [...] opening the library in a tab strikes me as completely useless."

Removing such an important feature so that it can be easier to implement opening the library in a tab is like putting your only car in the shop and riding the bus everywhere, just so that you can modify your doors to open a little wider.

Comment 18

6 years ago
I am absolutely horrified that this feature has been removed. I'm not going to go on a huge rant about why this feature should be kept, or how I'm switching browsers, I just wanted to say that I am really, really, upset. Like, lump in throat, I have never been this upset about software in my life. I really loved that feature, used it all the time.

...

How soon should I expect my saved searches to stop working? :(

Comment 19

6 years ago
When can we expect to get Search filters/scopes back? I don't care about saved searches, i care about narrowing the search results to specific folders (and their sub-folders)? 

I reverted to FF 18 ~3 weeks ago but FF 18 has display issues in periodically making all text fuzzy and unreadable. Go figure. Can you turn the scope bar code into an add-on so we can drag the functionality with us into FF19 etc. until you guys figure out what to do?

Comment 20

6 years ago
For those of you needing to upgrade past FF 18, but also not being able to live without your "search within this folder" option (like me), the addon SavedSearchButton 1.3 gets the job done.

https://addons.mozilla.org/en-US/firefox/addon/savedsearchbutton/

Comment 21

6 years ago
On a sidenote, I just realized I've been using at least two addons from that same developer (ShowParentFolder and GoParentFolder) for years.  Highly useful.

Comment 22

6 years ago
Thanks @JackG, you have saved my day.

Please, please, bring the fileter search back to us.

Comment 23

6 years ago
(In reply to Mano from comment #9)
> https://hg.mozilla.org/mozilla-central/rev/a2a201dd7a85

I noticed in places.xul that some commands in the commandset remain, such as:

    <command id="OrganizerCommand_search:save"
             oncommand="PlacesOrganizer.saveSearch();"/>

Was that an oversight?
(In reply to Hal Rand from comment #23)
> (In reply to Mano from comment #9)
> > https://hg.mozilla.org/mozilla-central/rev/a2a201dd7a85
> 
> I noticed in places.xul that some commands in the commandset remain, such as:
> 
>     <command id="OrganizerCommand_search:save"
>              oncommand="PlacesOrganizer.saveSearch();"/>
> 
> Was that an oversight?

yes, that looks like a leftover, please file it apart.

Comment 25

6 years ago
Hello, will this bar please be added back soon?  This feature was very helful for me.  Thank you

Comment 26

6 years ago
Thankfully, this Filter/Search functionality was reproduced in this extension:
https://addons.mozilla.org/en-US/firefox/addon/savedsearchbutton/

It works exactly as expected.

Also, I recommend getting these 2 other extensions (same author):

Show Parent: displays the bookmark's folder (very handy)
https://addons.mozilla.org/en-US/firefox/addon/show-parent-folder/?src=userprofile

Go Parent: right click on a bookmark, Go Parent will take you to the folder
https://addons.mozilla.org/en-US/firefox/addon/go-parent-folder/?src=userprofile
Depends on: 1320063
You need to log in before you can comment on or make changes to this bug.