Last Comment Bug 750574 - [10.8] Build fails with "arch: posix_spawnp: egrep: Bad CPU type in executable"
: [10.8] Build fails with "arch: posix_spawnp: egrep: Bad CPU type in executable"
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla15
Assigned To: Paul O'Shannessy [:zpao] (not reading much bugmail, email directly)
:
Mentors:
Depends on:
Blocks: mountain-lion-compat
  Show dependency treegraph
 
Reported: 2012-04-30 18:02 PDT by Paul O'Shannessy [:zpao] (not reading much bugmail, email directly)
Modified: 2012-10-08 10:35 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v0.1 (1.04 KB, patch)
2012-05-14 16:42 PDT, Paul O'Shannessy [:zpao] (not reading much bugmail, email directly)
ted: review+
ted: feedback+
Details | Diff | Review

Description Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2012-04-30 18:02:28 PDT
At least as of 10.8 DP3, it would appear that maybe Apple is no longer shipping universal binaries for (at least) egrep, so the fix we made to build on Lion (bug 655339) is no longer a valid option.

I just successfully built with FIXED_EGREP just pointing to egrep so perhaps we should go back to that.
Comment 1 Kyle Huey [:khuey] (khuey@mozilla.com) 2012-04-30 18:05:20 PDT
Why is this confidential?
Comment 2 Ted Mielczarek [:ted.mielczarek] 2012-05-01 04:01:22 PDT
I'm going to assume "accidentally".

Steven: is that grep workaround still necessary on current Lion? Could we simply remove it entirely?
Comment 3 Steven Michaud [:smichaud] (Retired) 2012-05-01 09:52:04 PDT
> Steven: is that grep workaround still necessary on current Lion?

Yes :-(

I just did a test build on OS X 10.7.3, with FIXED_EGREP pointing to egrep.

I suspect Apple will never fix bug 655339 on Lion (that they somehow consider that too big a change for a minor update).
Comment 4 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2012-05-01 10:32:20 PDT
I marked it confidential because I wasn't really sure where the line is for non-public information about 10.8. I figured it was better to start overly cautious.
Comment 5 Steven Michaud [:smichaud] (Retired) 2012-05-01 10:40:43 PDT
(In reply to comment #4)

My understanding is that we're free to discuss Apple's pre-release builds to the extent that they directly effects us (e.g. bugs that we'd need to work around; new features that we'd need to support).

I got this from Josh, and have followed it since I started working on Mozilla.
Comment 6 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2012-05-14 16:42:45 PDT
Created attachment 623867 [details] [diff] [review]
Patch v0.1

This is working on MoLo but not sure if it'll break anything else. I think this will only hit Lion and then for older versions we'll just use egrep as it was. That should be ok if only Lion AKA darwin 11 was broken (sounds like the case).
Comment 7 Ted Mielczarek [:ted.mielczarek] 2012-05-18 05:55:50 PDT
Comment on attachment 623867 [details] [diff] [review]
Patch v0.1

Review of attachment 623867 [details] [diff] [review]:
-----------------------------------------------------------------

That should be fine.
Comment 8 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2012-05-18 15:50:41 PDT
Comment on attachment 623867 [details] [diff] [review]
Patch v0.1

I pushed to try (https://tbpl.mozilla.org/?tree=Try&rev=2d3af9fda07e) and it looks fine, so let's make this official.
Comment 9 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2012-05-21 12:45:10 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/a0c0d4a72648
Comment 10 Ed Morley [:emorley] 2012-05-22 06:40:06 PDT
https://hg.mozilla.org/mozilla-central/rev/a0c0d4a72648

Note You need to log in before you can comment on or make changes to this bug.