Last Comment Bug 750588 - IonMonkey: webgl test failures on tbpl
: IonMonkey: webgl test failures on tbpl
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: David Anderson [:dvander]
:
Mentors:
Depends on:
Blocks: IonGreen
  Show dependency treegraph
 
Reported: 2012-04-30 19:19 PDT by David Anderson [:dvander]
Modified: 2012-05-01 14:08 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
test (1.15 KB, application/javascript)
2012-04-30 19:19 PDT, David Anderson [:dvander]
no flags Details
fix (1.44 KB, patch)
2012-05-01 11:53 PDT, David Anderson [:dvander]
sstangl: review+
Details | Diff | Review

Description David Anderson [:dvander] 2012-04-30 19:19:56 PDT
Created attachment 619813 [details]
test

Looks like a typed array bug. Got a reduced test case, sort of.
Comment 1 David Anderson [:dvander] 2012-04-30 19:37:01 PDT
Bug is that Float32Array requires conversion and this clobbers the input register. Will fix tomorrow.
Comment 2 David Anderson [:dvander] 2012-05-01 11:53:30 PDT
Created attachment 620006 [details] [diff] [review]
fix
Comment 3 David Anderson [:dvander] 2012-05-01 14:08:06 PDT
https://hg.mozilla.org/projects/ionmonkey/rev/374ab9121017

Note You need to log in before you can comment on or make changes to this bug.