Closed Bug 750645 Opened 8 years ago Closed 8 years ago

Seizure-inducing flicker on Fish IE demo

Categories

(Core :: Graphics: Layers, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 753742
Tracking Status
blocking-fennec1.0 --- +

People

(Reporter: cjones, Assigned: jrmuizel)

Details

STR
 (1) Load Fish IE in portrait orientation (http://ie.microsoft.com/testdrive/Performance/FishIETank/)
 (2) Zoom in on the demo while in portrait
 (3) Zoom back out

--- LOOK AWAY ---

 (4) Switch to landscape

I see a horrendous flicker that looks like a pure-white screen being rendered every other frame, canvas the odd frames.

(Guessing this is a layers issue instead of a 2d-canvas problem.)
Pretty bad bug.
blocking-fennec1.0: --- → ?
Assignee: nobody → jmuizelaar
blocking-fennec1.0: ? → +
There's more weirdness here, and the white flashing could just be another symptom.  For example:

 1) Load FishIE in portrait
    - note "control panel" doesn't appear on right side, and you can't pan to it; looks like it's off the side of the window to the right
 2) Rotate to landscape
 3) Pan around
    - note that there's white to the right and bottom of the canvas area
 4) try to click on any of the 'choose number of fish' links
    - doesn't work, canvas itself gets a yellow selection outline
 5) click in the white area to the right of the control panel/'choose number of fish' selection
    - the control panel gets selected, and if you hit it right, you can get one of the number of fish links to trigger by tapping in the white area

Also:

 1) Load FishIE in portrait
 2) Rotate to landscape
 3) Zoom in
    - note that screen goes wonky, and you don't really end up zooming in to what you expected; could be related to the above
 4) While zoomed in, rotate back to portait
    - canvas is stretched out
    - zoom out all the way
    - when you pinch to zoom out further, you can see content being drawn to the right... but you can't actually zoom out to see it, because the viewport seems to be locked
This simple testcase seems to reproduce much of the same issues above:

  http://conduit.bitops.com/~vladimir/misc/resize.html

trying to get it to reproduce the original white blinking though; i'm not sure if these are all related or not, but my guess is that the blinking is due to many resizes going on.
I filed bug 753069 for the above issues; I suspect that this is all the same issue, though.
FishIE tank uses overflow:hidden, so any of the issues could be caused by the same underlying bug as bug 747493.
This looks to be fixed by bug 753742
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Resolution: FIXED → DUPLICATE
Duplicate of bug: 753742
You need to log in before you can comment on or make changes to this bug.