Closed Bug 750734 Opened 7 years ago Closed 7 years ago

Virtual keyboard doesn't appear when opening Fennec with an url from an external application

Categories

(Firefox for Android :: Keyboards and IME, defect)

ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 15
Tracking Status
firefox14 --- fixed
firefox15 --- verified
blocking-fennec1.0 --- beta+

People

(Reporter: martijn.martijn, Assigned: bnicholson)

References

Details

(Keywords: regression, Whiteboard: [has reviewed patch])

Attachments

(1 file, 1 obsolete file)

Steps to reproduce:
- Open a mail client (in my case gmail)
- Tap on one of the bugzilla mails with the bugzilla url on it
- Choose Nightly as the application which you want to open the url with
- Tap on one of the input boxes in the bug

Expected result:
- Input gets focus, virtual keyboard appears

Actual result:
- Input gets focus, but virtual keyboard doesnt appear.

Tested on the Samsung Galaxy Nexus, Android 4.0.4.

I see this bug also on Aurora, I don't see it in XUL Fennec.
I can reproduce this, same use case same phone.
Can reproduce this on any site, ie., Twitter/Facebook
Brian - Can you dig into this and see if there is something in front-end causing it? Might be IME.
Assignee: nobody → bnicholson
blocking-fennec1.0: ? → beta+
Looks like an IME bug. We're calling showSoftInput() as expected, but it doesn't seem to be working. Here's a log: http://pastebin.mozilla.org/1611029

Here's the STR that I'm using:
1) From the AwesomeScreen, long tap http://bugzilla.mozilla.org and add it as a home screen shortcut.
2) Quit Fennec (menu > Quit).
3) Click the home screen shortcut.

This appears to only happen at startup for me. If, in step 2, I simply press home to minimize Fennec instead of quit, the keyboard shows up fine.
Attached patch patch (obsolete) — Splinter Review
According to the Android docs (http://developer.android.com/reference/android/view/inputmethod/InputMethodManager.html#showSoftInput%28android.view.View,%20int%29), the view parameter of showSoftInput() is "the currently focused view". I added a check to see whether the view is focused when this bug occurs, and it is not.

This patch ensures that the view is focused when the virtual keyboard is being shown.
Attachment #620151 - Flags: review?(cpeterson)
Attached patch patch 1.1Splinter Review
Removed some leftover logging
Attachment #620151 - Attachment is obsolete: true
Attachment #620151 - Flags: review?(cpeterson)
Attachment #620152 - Flags: review?(cpeterson)
Comment on attachment 620152 [details] [diff] [review]
patch 1.1

LGTM!
Attachment #620152 - Flags: review?(cpeterson) → review+
Whiteboard: [has reviewed patch]
http://hg.mozilla.org/mozilla-central/rev/e3a1a5c1aaa4
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 15
Comment on attachment 620152 [details] [diff] [review]
patch 1.1

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: keyboard won't appear when launching fennec from external apps
Testing completed (on m-c, etc.): just landed on m-c
Risk to taking this patch (and alternatives if risky): low risk
String changes made by this patch: none
Attachment #620152 - Flags: approval-mozilla-aurora?
Verified fixed in today's trunk build on the HTC Desire HD.
Status: RESOLVED → VERIFIED
Comment on attachment 620152 [details] [diff] [review]
patch 1.1

[Triage Comment]
Blocker for Fennec 1.0 Beta - approved for Aurora 14.
Attachment #620152 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Depends on: 760087
You need to log in before you can comment on or make changes to this bug.