Link not focused or highlighted on mousedown of ABBR/ACRONYM portion

RESOLVED DUPLICATE of bug 65917

Status

()

--
trivial
RESOLVED DUPLICATE of bug 65917
18 years ago
16 years ago

People

(Reporter: mpt, Assigned: attinasi)

Tracking

({testcase})

Trunk
Future
PowerPC
Mac System 9.x
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Build: 2001040408, Mac OS 9.1

To reproduce:
*   Load the attached testcase in Navigator.
*   Mousedown on the word `Visiting'.
*   Note that the link becomes focused, and it is highlighted with your default
    link highlight color (e.g. red).
*   Drag away from the link to cancel the link activation.
*   Now mousedown on the word `NASA'.

What should happen:
*   The link becomes focused.
*   The link is highlighted with your default link highlight color (e.g. red).

What actually happens:
*   Nothing.
(Reporter)

Comment 1

18 years ago
Created attachment 30030 [details]
testcase
Does this only happen with ABBR/ACRONYM or also with things like <b> and <code> 
and so on?

Chances are, this bug is due to :active and :focus not being hierarchical. See 
bug 65917, which discusses this exact situation....
HTML Element component is deprecated, and should be removed from Bugzilla.
Clayton is not the correct owner for these. Reassigning to layout.
Assignee: clayton → karnaze
Component: HTML Element → Layout
QA Contact: bsharma → petersen

Comment 4

17 years ago
I see something related to this bug on the followiung BBC news site:

http://news.bbc.co.uk/hi/english/world/

If you move the pointer over a headline, it gets highlighted in red (no
mousedown needed).  If you then use the mousewheel to scroll down, the link will
remain highlighted despite the fact that the pointer is no longer over it.  You
can highlight several links in a row by these means.

I guess it comes down to the fact that moving the page with the mousewheel does
not generate a "mouse move" event, even though the mouse has, in some sense
moved (relative to the page not the screen).

Interestingly, moving the page with the keyboard does not have this problem.

Similarly, if you move the page using the mousewheel, and your pointer happens
to end up on a link, it is not highlighted.

Another case of this is when you click a link, and you end up on the new page
with the mouse over link, that link will not be highlighted and you do not get
the "pointing finger" cursor.
Perhaps this should be a separate bug?

I'm using Linux, milestone 0.93, Gnome 1.2...

Comment 5

17 years ago
not a table specific bug. reassigning
Assignee: karnaze → attinasi

Updated

17 years ago
Target Milestone: --- → Future
Keywords: testcase

*** This bug has been marked as a duplicate of 65917 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.